[Pkg-fonts-devel] Bug#575753: python-fontforge: only compiled against python 2.5

Kęstutis Bilūnas kebil at kaunas.init.lt
Fri Jul 23 22:51:09 UTC 2010

Sk, 2010 03 28 22:14 +0000, rbrito at ime.usp.br rašė:
> Source: fontforge
> Severity: normal
> The current fontforge depends on python-all-dev, but its binary object is created
> only for python 2.5. Ideally, it should create binary objects for all versions
> that Debian supports.

I think that this is almost impossible. Fontforge does not have the
usual extension modules to bind FontForge program with python. All
FontForge libraries (libfontforge, libgutils and libgunicode) are
compiled and linked against a specific version of the python. And only
two very small and simple extension modules (fontforge and psMat) are
designed to bind theses libraries with python. So we would have all the
fontforge program with all its libraries to compile a few times and do
something very significant package. And who needs them? Is not enough
that the program works with the current default Debian Python version?

Best wishes,
Kęstutis Biliūnas <kebil at kaunas.init.lt>
http://kebil.ghost.lt  |  GnuPG-Key ID: F6E7A452
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.alioth.debian.org/pipermail/pkg-fonts-devel/attachments/20100724/a0c0b938/attachment.pgp>

More information about the Pkg-fonts-devel mailing list