[Pkg-fonts-devel] Bug#578634: fontforge: unflexible build system wtr dlopened files

Kęstutis Bilūnas kebil at kaunas.init.lt
Sat Jul 24 07:55:43 UTC 2010

Tr, 2010 04 21 09:12 -0300, Rogério Brito rašė:
> Package: fontforge
> Version: 0.0.20100401-1
> Severity: normal
> I am preparing a new version of fontforge and it seems that our build
> system could deal better with changes in the libraries loaded with
> dlopen.
> Right now, their versions are hardcoded in the paths that we use during
> build time and upstream has just bumped the micro version of
> /usr/lib/libgunicode.so.3.0.2.
> This means that our binaries can't load it at runtime (breaking a very
> useful---essential?) feature of a package meant to be multilingual.
> The failure should, as much as possible, be recognized at build time,
> not at run time.
> The patch attached on the next e-mail mitigates the situation for a
> little while.

I think that we can move a symbolic links (libfontforge.so, libgutils.so
and libgunicode.so) from libfontgorge-dev package to the libfontforge1
package and then override the lintian warnings  about it. In this case,
we can remove the patch 020_fix_pyext_path.diff and the build system
become more flexible.

What is your opinion on this?

Best wishes,
Kęstutis Biliūnas <kebil at kaunas.init.lt>

More information about the Pkg-fonts-devel mailing list