[Pkg-fonts-devel] Bug#575753: python-fontforge: only compiled against python 2.5

Jakub Wilk jwilk at debian.org
Sun Sep 25 19:38:02 UTC 2011

* Kęstutis Bilūnas <kebil at kaunas.init.lt>, 2010-07-24, 01:51:
>I think that this is almost impossible. Fontforge does not have the 
>usual extension modules to bind FontForge program with python. All 
>FontForge libraries (libfontforge, libgutils and libgunicode) are 
>compiled and linked against a specific version of the python. And only 
>two very small and simple extension modules (fontforge and psMat) are 
>designed to bind theses libraries with python. So we would have all the 
>fontforge program with all its libraries to compile a few times and do 
>something very significant package. And who needs them?

As a user of python-fontforge (but not fontforge itself), I would 
appreciate if I could use the module with non-standard Python versions.  
However, I see that the current design (which is a bit broken, in my 
humble opinion) makes implementing it infeasible.

Jakub Wilk

More information about the Pkg-fonts-devel mailing list