[pkg-fso-maint] install-info problem - Was: Re: not able to install debain on gta01 or gta02

Olivier Berger oberger at ouvaton.org
Sat Aug 22 10:59:55 UTC 2009

steffen_moeller at gmx.de (Steffen Moeller) writes:

> Hello,
> Sascha.P- at web.de wrote:
>> Installed by using:
>> HOSTNAME=bucky SD_PART1_FS=vfat SD_SWAP_SIZE=256 INST_MIRROR=http://ftp.es.debian.org/debian RDATEHOST= TESTHOST=www.google.com ./install.sh all
>> 2 BUGS :
>> ------------
>> #bug1
>> 	echo "BUG-patch:download manually: install-info_4.13a.dfsg.1-4_armel.deb..."
>> 	mkdir -p /mnt/debian/var/cache/bootstrap
>> 	cd /mnt/debian/var/cache/bootstrap
>  	wget $INST_MIRROR/pool/main/t/texinfo/install-info_4.13a.dfsg.1-4_armel.deb
> one could add such this to install.sh, but would you have insights on why this happens?

Trying to hunt the fix for that one, FWIW, here's the output of a run
with :
$ VERBOSE=yes INST_DIR=/media/card QI=true ./install.sh debian
P: Configuring helper cdebootstrap-helper-apt
O: Selecting previously deselected package cdebootstrap-helper-apt.
O: (Reading database ... 
O: 5939 files and directories currently installed.)
O: Unpacking cdebootstrap-helper-apt (from .../cdebootstrap-helper-apt.deb) ...
O: Setting up cdebootstrap-helper-apt (1) ...
O: Get:1 bootstrap: . Release.gpg [835B]
O: Get:2 bootstrap: . Release [100kB]
O: Ign bootstrap: ./main Packages/DiffIndex
O: Reading package lists...
O: Reading package lists...
O: Building dependency tree...
O: The following extra packages will be installed:
O:   install-info
O: Suggested packages:
O:   perl-modules runit iproute dhcp3-client dhcp-client ppp krb5-doc krb5-user
O:   ssh-askpass libpam-ssh keychain indent
O: Recommended packages:
O:   xauth openssh-blacklist openssh-blacklist-extra
O: The following NEW packages will be installed:
O:   adduser dropbear ifupdown install-info libbsd0 libedit2 libgssapi-krb5-2
O:   libk5crypto3 libkeyutils1 libkrb5-3 libkrb5support0 libssl0.9.8
O:   module-init-tools net-tools netbase openssh-client udev vim-common vim-tiny
O:   wget
O: 0 upgraded, 20 newly installed, 0 to remove and 0 not upgraded.
O: Need to get 0B/4859kB of archives.
O: After this operation, 13.1MB of additional disk space will be used.
O: WARNING: The following packages cannot be authenticated!
O:   udev adduser net-tools ifupdown install-info libssl0.9.8 module-init-tools
O:   netbase vim-common vim-tiny wget libbsd0 libedit2 libkeyutils1
O:   libkrb5support0 libk5crypto3 libkrb5-3 libgssapi-krb5-2 openssh-client
O:   dropbear
O: Authentication warning overridden.
O: Err bootstrap: ./main install-info 4.13a.dfsg.1-4
O: Failed to fetch bootstrap:/pool/main/t/texinfo/install-info_4.13a.dfsg.1-4_armel.deb  
O: E: 
O: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
E: Internal error: install

Hope this helps,

Best regards,
Olivier BERGER 
(OpenPGP: 1024D/B4C5F37F)

More information about the pkg-fso-maint mailing list