[pkg-fso-maint] phoneui-apps_0.1+git20100801-1_amd64.changes ACCEPTED

Timo Jyrinki timo.jyrinki at gmail.com
Fri Aug 6 21:15:00 UTC 2010

2010/8/6 Steffen Möller <steffen_moeller at gmx.de>:
> From what I read below, you'd want both  xf86-video-glamo
> and libdrm-glamo to see uploaded - right?

Well, the current situation is that the same xf86-video-glamo is
already uploaded to official archives, it's just a recompilation (with
another configure switch) in the pkg-fso. However, libdrm-glamo is
only useful with KMS/DRM in the kernel ie. openmoko branch of kernel
2.6.32, and we only have 2.6.29(-rc3ish) in pkg-fso. And as we have no
support at all for Openmoko phones in the official Debian kernel, I'm
not sure if it makes sense or not to have that stuff in.

On the other hand, all the other stuff is in as well even though
official Debian doesn't have the kernel support. It would be indeed
nice to have libdrm-glamo in, but it would probably only work out
properly if it would be given as a patch to libdrm sources - and I'm
not sure if libdrm maintainers want to carry that around, even though
the current squeeze version matches exactly what the current glamo
support is based on. It's possible anyhow.

Ideally I was thinking that libdrm glamo code would be upstreamed, but
it hasn't happened yet. I'm not sure if the author (Thomas White) has
willingness to do that. The libdrm-glamo package / patch in pkg-fso
would also probably need updating from [1]

[1] http://git.bitwiz.org.uk/?p=libdrm.git;a=summary

Regarding the kernel, git.openmoko.org's branches aren't enough, SHR
has a big bunch of patches [2] to their 2.6.32 to make things actually
work, like I mentioned in the latest community update [3].

[2] http://cgit.openembedded.org/cgit.cgi/openembedded/tree/recipes/linux/linux-openmoko-2.6.32
[3] http://wiki.openmoko.org/wiki/Community_Updates/2010-08-01


More information about the pkg-fso-maint mailing list