RFU: vdrift 0.0.2006.02.21-1

Sam Hocevar sam at zoy.org
Fri May 26 17:37:02 UTC 2006

On Fri, May 26, 2006, Gonéri Le Bouder wrote:

> > > IMHO there is no need to depend on the binary, apt frontends should
> > > discover packages in such situation (aptitude does this).
> >
> > apt-get doesn't and i can't imagine a new game that depends on
> > vdrift-data since this is not an official tarball. Maybe a different
> > flavor of the package like vdrift-sdl or vdrift-oss will be create. In
> > this case we can update vdrift-data depends.
> I switched back to "Depends:".
> If one day apt-get is able to deal with this situation, i will change it to 
> Recommends:

   This is wrong. apt-get is *not* able to deal with the current
situation (ie. circular dependencies). The -data package should not
depend on the binary package, so if you want to wait until apt-get is
fixed, you must remove the dependency (even Recommends: is useless).


More information about the Pkg-games-devel mailing list