Bug#386067: boson: error on upgrade: libbomeshrendererplugin.so owned by 2 packages

Ross Boylan ross at betterworld.us
Tue Sep 5 00:37:35 UTC 2006

Package: boson
Version: 0.11-4
Severity: normal

While doing aptitude dist-upgrade I get
Preparing to replace boson 0.11-4 (using .../boson_0.12dfsg1-1_i386.deb) ...
Unpacking replacement boson ...
dpkg: error processing /var/cache/apt/archives/boson_0.12dfsg1-1_i386.deb (--unpack):
 trying to overwrite `/usr/lib/kde3/plugins/boson/libbomeshrendererplugin.so', which is also in package boson-base
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:

I notice some related bugs pending upload, but none of them seem to
mention this particular file.

I expect that removing the package and then reinstalling will be a workaround.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing'), (990, 'stable'), (50, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-2-686-smp
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages boson depends on:
ii  boson-base                    0.11-4     core package for Boson
ii  boson-data                    0.12-1     Datas for Boson, a real-time strat
ii  boson-music                   0.11-2     Music Pack for Boson, a real-time 

boson recommends no packages.

-- no debconf information

More information about the Pkg-games-devel mailing list