Bug#430602: libode0-dev: should depend on libode0 (=version)

Eddy Petrișor eddy.petrisor at gmail.com
Tue Jun 26 13:16:49 UTC 2007

Gonéri Le Bouder wrote:
> severity 430602 serious
> thanks
> On Tue, Jun 26, 2007 at 12:34:48AM +0200, Jiří Paleček wrote:
>> Package: libode0-dev
>> Version: 1:0.8.dfsg-1
>> Severity: normal
>> Hello,
>> I think there should be a versioned dependency between the -dev
>> package and the library. If the user installed a newer -dev with older
>> library, he would probably not be able to link against the older
>> library (because of the new API).
> Yes you're right.

Make sure you use the upsteam source as version since there might be binNMUs and the API should not change anyway from
a.b.c-X to a.b.c-Y.

"Imagination is more important than knowledge" A.Einstein

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-games-devel/attachments/20070626/71d6be75/attachment.pgp 

More information about the Pkg-games-devel mailing list