r6744 - packages/trunk/openal-soft/debian

Stefan Potyra sistpoty at ubuntu.com
Fri Apr 25 23:02:38 UTC 2008


Am Donnerstag 24 April 2008 09:13:17 schrieb Andres Mejia:
> Adding Replaces field for older openal library packages
>  Depends: ${shlibs:Depends}
> +Replaces: libopenal0, libopenal0a

just a small hint: a library package should never replace another library 
package. It can only do so, if it is a replacement on the ABI level, but then 
of course it wouldn't need a different SONAME.

(fortunately, there is no conflicts there as well).

As an example, consider bar linked against libopenal0. The user has bar 
installed, and hence libopenal0 got drawn in. Now he/she chooses to upgrade 
to libopenal1, which would then replace (and hence remove) libopenal0. As a 
result, bar on the users system would no longer work, if it uses any symbol 
which is not present in libopenal1.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : http://lists.alioth.debian.org/pipermail/pkg-games-devel/attachments/20080426/12903bfd/attachment-0001.pgp 

More information about the Pkg-games-devel mailing list