Bug#530483: Needs update for new Boost

Steve M. Robbins smr at debian.org
Mon May 25 03:03:33 UTC 2009

Package: vegastrike
Severity: serious
Justification: no longer builds from source

Due to the recently-introduced package boost-defaults [1], the
unversioned Boost -dev packages changed from Boost version 1.34.1 to
version 1.38.0.

You package now fails to build due to that change.  Excerpt from Build Log:

        x86_64-linux-gnu-g++ -DHAVE_CONFIG_H -I.   -I/usr/include    -DHAVE_SDL=1 -DSDL_WINDOWING=1      -DHAVE_AL=1   -DHAVE_OGG  -DDATA_DIR=\"/usr/share/games/vegastrike\"  -I/usr/include/python2.5 -DHAVE_PYTHON=1    -I./src   -pipe  -O2 -ffast-math  -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -pthread -MT src/networking/lowlevel/vsnet_socketset.o -MD -MP -MF $depbase.Tpo -c -o src/networking/lowlevel/vsnet_socketset.o src/networking/lowlevel/vsnet_socketset.cpp &&\
        mv -f $depbase.Tpo $depbase.Po
In file included from /usr/include/c++/4.3/ext/hash_map:64,
                 from ./src/gnuhash.h:21,
                 from ./src/vsfilesystem.h:14,
                 from src/networking/lowlevel/vsnet_dloadenum.h:7,
                 from src/networking/lowlevel/vsnet_dloadmgr.h:17,
                 from src/networking/lowlevel/vsnet_socketset.cpp:9:
/usr/include/c++/4.3/backward/backward_warning.h:33:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
In file included from src/networking/lowlevel/vsnet_socketset.cpp:9:
src/networking/lowlevel/vsnet_dloadmgr.h:24: warning: declaration 'class VSFileSystem::VSFile' does not declare anything
src/networking/lowlevel/vsnet_socketset.cpp: In member function 'int SocketSet::private_select(timeval*)':
src/networking/lowlevel/vsnet_socketset.cpp:183: error: 'make_shared' is not a member of 'boost'
src/networking/lowlevel/vsnet_socketset.cpp:192: error: 'make_shared' is not a member of 'boost'
make[2]: *** [src/networking/lowlevel/vsnet_socketset.o] Error 1
make[2]: Leaving directory `/tmp/buildd/vegastrike-0.5~svn12126'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/buildd/vegastrike-0.5~svn12126'
make: *** [build-stamp] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2

[1] http://lists.debian.org/debian-devel-announce/2009/05/msg00002.html

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

More information about the Pkg-games-devel mailing list