Bug#570112: supertuxkart: There is a segfault that crashes the program

calbasi calbasi.LEAVE_IT_IF_YOU_ARE_NOT_SPAMMER at pangea.org
Tue Feb 16 15:52:33 UTC 2010

Package: supertuxkart
Version: 0.6.2+dfsg1-1
Severity: normal

Just the program doesn't run in my computer... When I execute it , nothing happens. 

If I do it from a terminal, then I've got this error:

$ supertuxkart
Data files will be fetched from: '/usr/share/games/supertuxkart/'
Config file '/home/joan/.supertuxkart/config' does not exist, it will be created.
Violació de segment (that means segment violation in Catalan)


dmesg -r command show:

<6>[22332.065433] supertuxkart[9899]: segfault at b7121ff4 ip b6b3b004 sp bfd9243b error 7 in libcap.so.2.17[b6b3b000+3000]
<6>[22357.942045] supertuxkart[10027]: segfault at b7183ff4 ip b6b9d004 sp bfa29cdb error 7 in libcap.so.2.17[b6b9d000+3000]
<6>[22475.025835] supertuxkart[10546]: segfault at b7143ff4 ip b6b5d004 sp bff8108b error 7 in libcap.so.2.17[b6b5d000+3000]
<6>[22602.997662] supertuxkart[11144]: segfault at b70fdff4 ip b6b17004 sp bfb8c9cb error 7 in libcap.so.2.17[b6b17000+3000]
<6>[23704.908364] supertuxkart[16376]: segfault at b7174ff4 ip b6b8e004 sp bfc1df8b error 7 in libcap.so.2.17[b6b8e000+3000]

(a line for time I've tried to execute it)

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-trunk-686 (SMP w/1 CPU core)
Locale: LANG=ca_ES.UTF-8, LC_CTYPE=ca_ES.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages supertuxkart depends on:
ii  freeglut3                  2.4.0-9       OpenGL Utility Toolkit
ii  libc6                      2.10.2-2      GNU C Library: Shared libraries
ii  libgcc1                    1:4.4.2-9     GCC support library
ii  libgl1-mesa-glx [libgl1]   7.6.1-1       A free implementation of the OpenG
ii  libglu1-mesa [libglu1]     7.6.1-1       The OpenGL utility library (GLU)
ii  libopenal1                 1:1.10.622-1  Software implementation of the Ope
ii  libplib1                   1.8.5-5       Portability Libraries: Run-time pa
ii  libsdl1.2debian            1.2.13-5      Simple DirectMedia Layer
ii  libstdc++6                 4.4.2-9       The GNU Standard C++ Library v3
ii  libvorbisfile3             1.2.3-3       The Vorbis General Audio Compressi
ii  supertuxkart-data          0.6.2+dfsg1-1 data for the supertuxkart kart rac

supertuxkart recommends no packages.

supertuxkart suggests no packages.

-- no debconf information

More information about the Pkg-games-devel mailing list