Bug#611406: wesnoth: The configure script searchs for SDL_net.h in the wrong directory

Daniel electrodan at hotmail.com
Fri Jan 28 23:36:01 UTC 2011

Package: wesnoth
Version: 1:1.4.4-2+lenny1
Severity: important
Justification: fails to build from source

The configure script outputs:

checking SDL_net.h usability... no
checking SDL_net.h presence... no
checking for SDL_net.h... no
configure: error: *** SDL_net include files not found!
You should install development package.

The package libsdl-net1.2-dev is installed.
The configuration runs sucessfully after executing:
ln -s /usr/include/SDL/SDL_net.h /usr/include

-- System Information:
Debian Release: 5.0.7
  APT prefers stable
  APT policy: (990, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/1 CPU core)
Locale: LANG=es_UY.UTF-8, LC_CTYPE=es_UY.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages wesnoth depends on:
ii  libboost-iostreams1.34 1.34.1-14         Boost.Iostreams Library
ii  libc6                  2.7-18lenny7      GNU C Library: Shared libraries
ii  libfreetype6           2.3.7-2+lenny4    FreeType 2 font engine, shared lib
ii  libfribidi0            0.10.9-1          Free Implementation of the Unicode
ii  libgcc1                1:4.3.2-1.1       GCC support library
ii  libsdl-image1.2        1.2.6-3           image loading library for Simple D
ii  libsdl-mixer1.2        1.2.8-4           mixer library for Simple DirectMed
ii  libsdl-net1.2          1.2.7-2           network library for Simple DirectM
ii  libsdl1.2debian        1.2.13-2          Simple DirectMedia Layer
ii  libstdc++6             4.3.2-1.1         The GNU Standard C++ Library v3
ii  libx11-6               2:1.1.5-2         X11 client-side library
ii  wesnoth-data           1:1.4.4-2+lenny1  data files for Wesnoth
ii  zlib1g                 1: compression library - runtime

Versions of packages wesnoth recommends:
ii  wesnoth-httt            1:1.4.4-2+lenny1 Heir to the Throne official campai
ii  wesnoth-tsg             1:1.4.4-2+lenny1 The South Guard official campaign 
ii  wesnoth-ttb             1:1.4.4-2+lenny1 A Tale of Two Brothers official ca

Versions of packages wesnoth suggests:
pn  wesnoth-all                   <none>     (no description available)

-- no debconf information

More information about the Pkg-games-devel mailing list