Bug#641386: pathogen: FTBFS with ld that defaults to --as-needed: bad linkage order

Alex Chiang achiang at canonical.com
Tue Sep 13 04:56:45 UTC 2011

Package: pathogen
Version: 1.1.1-2
Severity: important
Tags: patch
User: ubuntu-devel at lists.ubuntu.com
Usertags: origin-ubuntu oneiric ubuntu-patch

In Ubuntu, the attached patch was applied to achieve the following:

  * 01_Makefile.diff: update to fix FTBFS with ld that defaults to --as-needed
    (LP: #770915)

Thanks for considering the patch.

-- System Information:
Debian Release: squeeze/sid
  APT prefers natty-updates
  APT policy: (500, 'natty-updates'), (500, 'natty-security'), (500, 'natty')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.38-11-generic (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
-------------- next part --------------
A non-text attachment was scrubbed...
Name: tmpwAnq8M
Type: text/x-diff
Size: 1317 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-games-devel/attachments/20110912/64927cf7/attachment.diff>

More information about the Pkg-games-devel mailing list