Bug#340892: libbonobo: debian/watch file seems bound to GNOME 2.8.x, though current package is for 2.10.1, and upstream is at 2.13.0

Daniel Kahn Gillmor dkg-debian.org at fifthhorseman.net
Sat Nov 26 18:40:17 UTC 2005

Package: libbonobo
Severity: normal
Tags: patch

The existing debian/watch file for libbonobo seems to be capable of
only detecting libbonobo versions 2.8.x.  Given that the current
version of libbonobo in debian is 2.10.1, and the current released
version from GNOME is 2.13.0, the existing watchfile isn't very

The following watchfile should work for any released version of
libbonobo (i borrowed the regex of this watchfile from zenity's

[dkg at squeak libbonobo]$ cat debian/watch
http://ftp.gnome.org/pub/gnome/sources/libbonobo/([\d\.]+)/libbonobo-([\d\.]+)\.tar\.gz debian uupdate
[dkg at squeak libbonobo]$ 

Thanks for maintaining this package!


-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (700, 'testing'), (700, 'stable'), (600, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-1-686
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

More information about the Pkg-gnome-maintainers mailing list