Bug#333477: libgtk2.0-bin: Does not update IM module API - libxfce.so: undefined symbol: im_module_list

Javier de la Cueva jdelacueva at derecho-internet.org
Wed Oct 12 16:31:50 UTC 2005

El Miércoles, 12 de Octubre de 2005 16:59, Loïc Minier escribió:
>  Please report the result of dpkg -S libxfce.so.  Then please report the
>  output of "ldd" on that file.

# dpkg -S libxfce.so
	gtk2-engines-xfce: /usr/lib/gtk-2.0/2.4.0/engines/libxfce.so

# ldd /usr/lib/gtk-2.0/2.4.0/immodules/libxfce.so
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x6fc44000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x6fb8d000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x6fb49000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x6fb10000)
        libm.so.6 => /lib/tls/libm.so.6 (0x6fa7a000)
        libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0x6fa52000)
        libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0x6fa26000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x6f9c6000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x6f95e000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x6f93a000)
        libdl.so.2 => /lib/tls/libdl.so.2 (0x6f916000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x6f857000)
        libc.so.6 => /lib/tls/libc.so.6 (0x6f6f6000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x6f5ee000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x6f5a5000)
        libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0x6f581000)
        libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x6f557000)
        libXinerama.so.1 => /usr/X11R6/lib/libXinerama.so.1 (0x6f534000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x6f4ff000)
        libXft.so.2 => /usr/lib/libXft.so.2 (0x6f4cc000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x6f431000)
        libz.so.1 => /usr/lib/libz.so.1 (0x6f3fc000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x6f3a5000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x6f37a000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0x6f350000)
        /lib/ld.so.1 (0x08000000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x6f30a000)

# apt-get install gtk2-engines-xfce
	Reading package lists... Done
	Building dependency tree... Done
	gtk2-engines-xfce is already the newest version.
	0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
	1 not fully installed or removed.
	Need to get 0B of archives.
	After unpacking 0B of additional disk space will be used.
	Setting up libgtk2.0-bin (2.6.10-1) ...
	Updating the IM modules list for 	
GTK+-2.4.0.../usr/lib/gtk-2.0/2.4.0/immodules/libxfce.so does not export GTK+ 
IM module API: `im_module_list': /usr/lib/gtk-2.0/2.4.0/immodules/libxfce.so:  
undefined symbol: im_module_list
	dpkg: error processing libgtk2.0-bin (--configure):
 	subprocess post-installation script returned error exit status 1
	Errors were encountered while processing:
	E: Sub-process /usr/bin/dpkg returned an error code (1)

Best regards,
Javier de la Cueva

More information about the Pkg-gnome-maintainers mailing list