Bug#329924: libgnome2-common: Installation fails (postinst) GConf-ERROR **: ...

matt wanderer at netikka.fi
Sat Sep 24 13:03:40 UTC 2005

Package: libgnome2-common
Version: 2.10.1-1
Severity: grave
Justification: renders package unusable

*** Please type your report below this line ***

# apt-get -f install

Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 399 not upgraded.
2 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up libgnome2-common (2.10.1-1) ...
No such file `/usr/lib/GConf/2/libgconfbackend-xml.so'

// Copied /usr/lib/GConf/1 directory as /2

// Then new try:

# apt-get -f install

Setting up libgnome2-common (2.10.1-1) ...
/var/lib/dpkg/info/libgnome2-common.postinst: line 7: 15593 Segmentation fault      
HOME=/root GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` gconftool-2 
dpkg: error processing libgnome2-common (--configure):
 subprocess post-installation script returned error exit status 139
 dpkg: dependency problems prevent configuration of libgnome2-0:
  libgnome2-0 depends on libgnome2-common (= 2.10.1-1); however:
    Package libgnome2-common is not configured yet.
    dpkg: error processing libgnome2-0 (--configure):
     dependency problems - leaving unconfigured
     Errors were encountered while processing:
       E: Sub-process /usr/bin/dpkg returned an error code (1)

// check for gconftool :
# gconftool-2 --get-default-source

// My guess, wrong gconftool line. 
// Missing `` markings for the second gconftool command.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (900, 'unstable'), (850, 'testing'), (800, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12
Locale: LANG=en_IE at euro, LC_CTYPE=en_IE at euro (charmap=ISO-8859-15)

Versions of packages libgnome2-common depends on:
ii  gconf2                        2.10.1-5   GNOME configuration database 

libgnome2-common recommends no packages.

-- no debconf information

More information about the Pkg-gnome-maintainers mailing list