Bug#329924: libgnome2-common: Installation fails (postinst) GConf-ERROR **: ...

Vesa Voutilainen wanderer at netikka.fi
Sat Sep 24 15:50:14 UTC 2005

On Saturday 24 September 2005 16:49, Josselin Mouette wrote:
> Le samedi 24 septembre 2005 à 16:03 +0300, matt a écrit :
> > Package: libgnome2-common
> > Version: 2.10.1-1
> > Severity: grave
> > Justification: renders package unusable
> >
> > *** Please type your report below this line ***
> >
> > # apt-get -f install
> >
> > Reading package lists... Done
> > Building dependency tree... Done
> > 0 upgraded, 0 newly installed, 0 to remove and 399 not upgraded.
> > 2 not fully installed or removed.
> > Need to get 0B of archives.
> > After unpacking 0B of additional disk space will be used.
> > Setting up libgnome2-common (2.10.1-1) ...
> > No such file `/usr/lib/GConf/2/libgconfbackend-xml.so'
> Did you upgrade gconf2 in the same run?

Booted system up this morning, with gconfd 2.10.1, then later on upgraded 
gnome based files as a bunch, with kde did the same thing, first upgraded 
auxiliary things not related to kde, then big amount of kde core components 
at the same time, had previously trouble with partial upgrades, so tried to 
upgrade as much as possible which are related to each other. With kde 
everything worked, with gnome no.

From boot:

Sep 24 09:46:39 localhost gconfd (tampio-2886): starting (version 2.10.1), pid 
2886 user 'tampio'
Sep 24 09:46:40 localhost gconfd (tampio-2886): Resolved address 
"xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration 
source at position 0

So big bunch of gnome files were updated simultaneously. 

> Was a gconfd-2 process owned by
> root still running? If you kill it, does the upgrade work?

Probably, didn't look at the processes at that time. Nope, it is not running 
anymore and install won't work.

As before Sarge, I'll try to fork dpkg's package list with force commands, 
then by hand. Seems that the list is not possible to get into working order 
by normal means, but as soon as I get that latest version changed to working 
one, I'll try another install and watch processes at that time. 

> > // Copied /usr/lib/GConf/1 directory as /2
> Why do people keep doing such stupid things?

Because couple of days ago, for another package, I fixed same kind of problem 
with same type of action.

After I get this dpkg problem fixed and old versions running, I'll remove that 
directory, will see if upgrade works any better.

Yep, this time I'll try to update them one after another.

More information about the Pkg-gnome-maintainers mailing list