Bug#354034: epiphany-browser: Please use native avahi API instead of Howl emulation

Jerome Warnier jwarnier at beeznest.net
Wed Feb 22 20:38:18 UTC 2006

Package: epiphany-browser
Version: 1.8.5-1
Severity: wishlist

I guess this is an upstream problem.

It shows this on startup:
*** WARNING *** The programme 'epiphany' uses the HOWL compatiblity
layer of Avahi.
*** WARNING *** Please fix your application to use the native API of
*** WARNING *** For more information see


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-686
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages epiphany-browser depends on:
ii  gconf2                   2.12.1-9        GNOME configuration database syste
ii  gnome-icon-theme         2.12.1-2        GNOME Desktop icon theme
ii  iso-codes                0.49-1          ISO language, territory, currency 
ii  libart-2.0-2             2.3.17-1        Library of functions for 2D graphi
ii  libatk1.0-0              1.10.3-1        The ATK accessibility toolkit
ii  libaudiofile0            0.2.6-6         Open-source version of SGI's audio
ii  libavahi-client3         0.6.7-1         Avahi client library
ii  libavahi-common3         0.6.7-1         Avahi common library
ii  libavahi-compat-howl0    0.6.7-1         Avahi Howl compatibility library
ii  libbonobo2-0             2.10.1-1        Bonobo CORBA interfaces library
ii  libbonoboui2-0           2.10.1-2        The Bonobo UI library
ii  libc6                    2.3.6-1         GNU C Library: Shared libraries an
ii  libcairo2                1.0.2-3         The Cairo 2D vector graphics libra
ii  libdbus-1-2              0.60-6          simple interprocess messaging syst
ii  libdbus-glib-1-2         0.60-6          simple interprocess messaging syst
ii  libesd-alsa0 [libesd0]   0.2.36-3        Enlightened Sound Daemon (ALSA) - 
ii  libfontconfig1           2.3.2-2         generic font configuration library
ii  libfreetype6             2.1.10-1        FreeType 2 font engine, shared lib
ii  libgcc1                  1:4.0.2-9       GCC support library
ii  libgconf2-4              2.12.1-9        GNOME configuration database syste
ii  libgcrypt11              1.2.2-1         LGPL Crypto library - runtime libr
ii  libglade2-0              1:2.5.1-2       library to load .glade files at ru
ii  libglib2.0-0             2.8.6-1         The GLib library of C routines
ii  libgnome-desktop-2       2.12.2-2        Utility library for loading .deskt
ii  libgnome-keyring0        0.4.7-1         GNOME keyring services library
ii  libgnome2-0          The GNOME 2 library - runtime file
ii  libgnomecanvas2-0        2.12.0-2        A powerful object-oriented display
ii  libgnomeprint2.2-0       2.12.1-3        The GNOME 2.2 print architecture -
ii  libgnomeprintui2.2-0     2.12.1-2        GNOME 2.2 print architecture User 
ii  libgnomeui-0             2.12.1-1        The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0           2.12.2-6        GNOME virtual file-system (runtime
ii  libgnutls12              1.2.9-2         the GNU TLS library - runtime libr
ii  libgpg-error0            1.1-4           library for common error values an
ii  libgtk2.0-0              2.8.12-1        The GTK+ graphical user interface 
ii  libice6                  6.9.0.dfsg.1-4  Inter-Client Exchange library
ii  libjpeg62                6b-11           The Independent JPEG Group's JPEG 
ii  libmozjs0d            The Mozilla SpiderMonkey JavaScrip
ii  libnspr4-0d           NetScape Portable Runtime Library
ii  liborbit2                1:2.12.4-1      libraries for ORBit2 - a CORBA ORB
ii  libpango1.0-0            1.10.3-1        Layout and rendering of internatio
ii  libpng12-0               1.2.8rel-5      PNG library - runtime
ii  libpopt0                 1.7-5           lib for parsing cmdline parameters
ii  libsm6                   6.9.0.dfsg.1-4  X Window System Session Management
ii  libstartup-notification0 0.8-1           library for program launch feedbac
ii  libstdc++6               4.0.2-9         The GNU Standard C++ Library v3
ii  libtasn1-2               0.2.17-1        Manage ASN.1 structures (runtime)
ii  libx11-6                 6.9.0.dfsg.1-4  X Window System protocol client li
ii  libxcursor1              1.1.3-1         X cursor management library
ii  libxext6                 6.9.0.dfsg.1-4  X Window System miscellaneous exte
ii  libxi6                   6.9.0.dfsg.1-4  X Window System Input extension li
ii  libxinerama1             6.9.0.dfsg.1-4  X Window System multi-head display
ii  libxml2                  2.6.23.dfsg.2-2 GNOME XML library
ii  libxrandr2               6.9.0.dfsg.1-4  X Window System Resize, Rotate and
ii  libxrender1              1:     X Rendering Extension client libra
ii  libxslt1.1               1.1.15-4        XSLT processing library - runtime 
ii  libxul0d              Gecko engine library
ii  python2.3                2.3.5-9         An interactive high-level object-o
ii  xulrunner             XUL + XPCOM application runner
ii  zlib1g                   1:1.2.3-9       compression library - runtime

Versions of packages epiphany-browser recommends:
pn  epiphany-extensions           <none>     (no description available)
ii  yelp                          2.12.2-4   Help browser for GNOME 2

-- debconf information:
* epiphany-browser/prefs-change-0.7.1:

More information about the Pkg-gnome-maintainers mailing list