Bug#345602: gnome-office needs a better description or revision of dependencies

Filipus Klutiero cheal at hotpop.com
Mon Jan 2 06:08:02 UTC 2006

Package: gnome-office
Version: 1:
Severity: normal

It is not clear what exactly is the gnome-office package. By looking at
the package's dependencies, one can find out what it is, but there is no
real way to figure that from the package description.
The first paragraph of the description seems to be the most misleading
one, saying that the package provides "The GNOME Office suite". Googling
"GNOME Office suite" brings as first result
http://www.gnome.org/gnome-office/ which does not use the term "GNOME
Office suite". This page explains why the package depends on AbiWord and
Gnumeric, but not the other dependencies. Later in the top 10 Google
results the Debian package page is found, then a klik one.
The second paragraph of the description explains the other dependencies,
but the two paragraphs seem to be inconsistent. One would expect to
only find details in the second paragraph.

I don't know what "GNOME Office suite" means. The package description
should either stop using that term or clarify what it means
(Debian-specific term?). If the term is Debian-specific, addressing
#335855 would be a good idea.

-- System Information:
Debian Release: 3.1
Architecture: i386 (i686)
Kernel: Linux 2.6.11
Locale: LANG=fr_CA, LC_CTYPE=fr_CA (charmap=ISO-8859-1)

Versions of packages gnome-office depends on:
pn  abiword-gnome                            Not found.
pn  dia-gnome                                Not found.
ii  gimp                          2.2.6-1    The GNU Image Manipulation Program
ii  gnome-core                    64         The GNOME Desktop Environment -- e
ii  gnumeric                      1.4.3-4    GNOME spreadsheet application
pn  inkscape | sodipodi                      Not found.
pn  planner                                  Not found.

More information about the Pkg-gnome-maintainers mailing list