Bug#345438: marked as done (libgnomevfs2-common: The default url-handler for http and https should not be epiphany)

Debian Bug Tracking System owner at bugs.debian.org
Sun Jan 15 18:19:50 UTC 2006

Your message dated Sun, 15 Jan 2006 09:46:59 -0800
with message-id <E1EyBxz-000489-2L at spohr.debian.org>
and subject line Bug#345438: fixed in gnome-vfs2 2.12.2-4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 31 Dec 2005 14:46:54 +0000
>From mh at glandium.org Sat Dec 31 06:46:54 2005
Return-path: <mh at glandium.org>
Received: from aputeaux-153-1-67-76.w81-249.abo.wanadoo.fr ([] helo=namakemono.glandium.org)
	by spohr.debian.org with esmtp (Exim 4.50)
	id 1Esi0T-0005IO-MP
	for submit at bugs.debian.org; Sat, 31 Dec 2005 06:46:53 -0800
Received: from mh by namakemono.glandium.org with local (Exim 4.60)
	(envelope-from <mh at glandium.org>)
	id 1Eshzx-0002rz-SA; Sat, 31 Dec 2005 15:46:21 +0100
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Mike Hommey <mh at glandium.org>
To: Debian Bug Tracking System <submit at bugs.debian.org>
Subject: libgnomevfs2-common: The default url-handler for http and https should not
 be epiphany
Message-ID: <20051231144621.10921.14567.reportbug at namakemono.glandium.org>
X-Mailer: reportbug 3.18
Date: Sat, 31 Dec 2005 15:46:21 +0100
Delivered-To: submit at bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.5 required=4.0 tests=BAYES_00,HAS_PACKAGE,
	RCVD_IN_SORBS autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: libgnomevfs2-common
Version: 2.12.2-1
Severity: wishlist

Currently, when you use any libgnomevfs2 dependant software, it will
handle http requests with the /desktop/gnome/url-handlers/http/command
gconf key (and https respectively), which default value is epiphany
even if epiphany is not installed.

A better way to handle this would be to put sensible-browser or
x-www-browser as the default value.

Interestingly, this default value has changed since I filed #247089,
which is a similar issue for gnome-mime-data and text/html mime type,
and at that time, /desktop/gnome/url-handlers/http/command was
sensible-browser while /desktop/gnome/url-handlers/https/command was
epiphany. Some change there would also be appreciated.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.14-2-686
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8)

Versions of packages libgnomevfs2-common depends on:
ii  gconf2        2.12.1-5                   GNOME configuration database syste
ii  gnome-mime-da 2.4.2-1                    base MIME and Application database
ii  libbonobo2-0  2.10.1-1                   Bonobo CORBA interfaces library
ii  libbz2-1.0    1.0.2-11                   high-quality block-sorting file co
ii  libc6         2.3.5-9                    GNU C Library: Shared libraries an
ii  libcomerr2    1.38+1.39-WIP-2005.12.10-1 common error description library
ii  libdbus-1-2   0.60-2                     simple interprocess messaging syst
ii  libdbus-glib- 0.60-2                     simple interprocess messaging syst
ii  libfam0       2.7.0-8                    client library to control the FAM 
ii  libgconf2-4   2.12.1-5                   GNOME configuration database syste
ii  libgcrypt11   1.2.2-1                    LGPL Crypto library - runtime libr
ii  libglib2.0-0  2.8.4-2                    The GLib library of C routines
ii  libgnomevfs2- 2.12.2-1                   The GNOME virtual file-system libr
ii  libgnutls11   1.0.16-14                  GNU TLS library - runtime library
ii  libgpg-error0 1.1-4                      library for common error values an
ii  libhal-storag                  Hardware Abstraction Layer - share
ii  libhal1                  Hardware Abstraction Layer - share
ii  libkrb53      1.4.3-5                    MIT Kerberos runtime libraries
ii  liborbit2     1:2.12.4-1                 libraries for ORBit2 - a CORBA ORB
ii  libpopt0      1.7-5                      lib for parsing cmdline parameters
ii  libsmbclient  3.0.20b-4                  shared library that allows applica
ii  libtasn1-2    0.2.17-1                   Manage ASN.1 structures (runtime)
ii  libxml2       2.6.22-2                   GNOME XML library
ii  shared-mime-i 0.16-3                     FreeDesktop.org shared MIME databa
ii  zlib1g        1:1.2.3-9                  compression library - runtime

libgnomevfs2-common recommends no packages.

-- no debconf information

Received: (at 345438-close) by bugs.debian.org; 15 Jan 2006 17:52:41 +0000
>From joerg at spohr.debian.org Sun Jan 15 09:52:41 2006
Return-path: <joerg at spohr.debian.org>
Received: from joerg by spohr.debian.org with local (Exim 4.50)
	id 1EyBxz-000489-2L; Sun, 15 Jan 2006 09:46:59 -0800
From: Josselin Mouette <joss at debian.org>
To: 345438-close at bugs.debian.org
X-Katie: lisa $Revision: 1.31 $
Subject: Bug#345438: fixed in gnome-vfs2 2.12.2-4
Message-Id: <E1EyBxz-000489-2L at spohr.debian.org>
Sender: Joerg Jaspert <joerg at spohr.debian.org>
Date: Sun, 15 Jan 2006 09:46:59 -0800
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Source: gnome-vfs2
Source-Version: 2.12.2-4

We believe that the bug you reported is fixed in the latest version of
gnome-vfs2, which is due to be installed in the Debian FTP archive:

  to pool/main/g/gnome-vfs2/gnome-vfs2_2.12.2-4.diff.gz
  to pool/main/g/gnome-vfs2/gnome-vfs2_2.12.2-4.dsc
  to pool/main/g/gnome-vfs2/libgnomevfs2-0-dbg_2.12.2-4_i386.deb
  to pool/main/g/gnome-vfs2/libgnomevfs2-0_2.12.2-4_i386.deb
  to pool/main/g/gnome-vfs2/libgnomevfs2-bin_2.12.2-4_i386.deb
  to pool/main/g/gnome-vfs2/libgnomevfs2-common_2.12.2-4_all.deb
  to pool/main/g/gnome-vfs2/libgnomevfs2-dev_2.12.2-4_i386.deb
  to pool/main/g/gnome-vfs2/libgnomevfs2-extra_2.12.2-4_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 345438 at bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Josselin Mouette <joss at debian.org> (supplier of updated gnome-vfs2 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster at debian.org)

Hash: SHA1

Format: 1.7
Date: Wed, 11 Jan 2006 00:26:15 +0100
Source: gnome-vfs2
Binary: libgnomevfs2-dev libgnomevfs2-extra libgnomevfs2-0-dbg libgnomevfs2-bin libgnomevfs2-0 libgnomevfs2-common
Architecture: source i386 all
Version: 2.12.2-4
Distribution: unstable
Urgency: low
Maintainer: Josselin Mouette <joss at debian.org>
Changed-By: Josselin Mouette <joss at debian.org>
 libgnomevfs2-0 - GNOME virtual file-system (runtime libraries)
 libgnomevfs2-0-dbg - GNOME virtual file-system (debugging libraries)
 libgnomevfs2-bin - GNOME virtual file-system (support binaries)
 libgnomevfs2-common - GNOME virtual file-system (common files)
 libgnomevfs2-dev - GNOME virtual file-system library (development files)
 libgnomevfs2-extra - GNOME virtual file-system (extra modules)
Closes: 316437 325383 344601 345438 346498
 gnome-vfs2 (2.12.2-4) unstable; urgency=low
   * Set myself as maintainer.
   * libgnomevfs2-common.gconf-defaults: make gnome-www-browser the
     default for http and https protocols (closes: #345438).
     - Build-depend on debhelper 5.0.13.
   * rules: build the doc with --enable-gtk-doc.
     - Build-depend on gtk-doc-tools.
     - Don't compress it.
   * Enable howl through libavahi-compat-howl-dev (closes: #346498).
     - Build-depend on it.
     - Also build-depend on libavahi-client-dev because of bug 347247.
     - Add them to the libgnomevfs2-dev dependencies.
   * A few cleanups:
     - libgnomevfs2-common.dirs: removed, unused.
     - Fix section and priority for libgnomevfs2-0-dbg.
     - Remove old conflicts and replaces.
     - Remove libgnomevfs2-common.{preinst,postrm}, unnecessary when
       upgrading from sarge.
     - Remove shlibs.local, it generates broken dependencies.
   * Break the dependency cycle (closes: #316437).
     - rules: change libexecdir, to put the daemon in /usr/lib/gnome-vfs-2.0.
     - Put example binaries in libgnomevfs2-bin.
     - Install the daemon, the moniker and the default modules in
       /usr/lib/gnome-vfs-2.0 in the libgnomevfs2-0 package.
       + 04_moniker_libexecdir.patch: use the moniker in this place.
     - This makes libgnomevfs2-common architecture-independent.
   * Split the bzip2, dns-sd and samba modules in a separate
     libgnomevfs2-extra package (closes: #344601).
   * 05_gnomevfs-ls.patch: stolen upstream. Reports correct sizes for
     files larger than 4 GB (closes: #325383).
   * defaults.list: update to MIME types supported by GNOME 2.12
   * Standards-version is 3.6.2.
   * Pass --as-needed to the linker to avoid unnecessary dependencies.
 fd5a54406a7e7d45b4605a064f547a9b 2168 libs optional gnome-vfs2_2.12.2-4.dsc
 b738c6ca5bbbfb6057217892cbf56519 14604 libs optional gnome-vfs2_2.12.2-4.diff.gz
 e25fdff8c118db63e96ee0e101f53ce2 991090 libs optional libgnomevfs2-common_2.12.2-4_all.deb
 75e18f9e6072f11ac1ea90d25e4fb7f1 588316 libs optional libgnomevfs2-0_2.12.2-4_i386.deb
 bb30231f3b1b8753f7a42a6996c65cd0 276654 libs optional libgnomevfs2-bin_2.12.2-4_i386.deb
 fcf9ddc8b09911d26203b0c743a858a7 279842 libs optional libgnomevfs2-extra_2.12.2-4_i386.deb
 53a89453c398677f925c66774b76e728 990494 libdevel extra libgnomevfs2-0-dbg_2.12.2-4_i386.deb
 7d13468729b19cf02d74a1f33765ce54 495326 libdevel optional libgnomevfs2-dev_2.12.2-4_i386.deb

Version: GnuPG v1.4.2 (GNU/Linux)


More information about the Pkg-gnome-maintainers mailing list