Bug#378199: gksu should conflict with libgksu0

Andreas Schmidt pi.c at tiscali.de
Fri Jul 14 07:30:27 UTC 2006

Package: gksu
Version: 1.9.1-2
Severity: normal

Apparently, the dependencies for gksu_1.9.1-2 aren't quite correct. It
replaces, but doesn't conflict with  libgksu0. Thus, libgksu0 is not removed
from the system. When trying to update libgksu2-0, I got an error because it
tried to overwrite a file that also was installed by libgksu0. Manually
removing libgksu0 fixed this problem. So it would be great if you could add
a conflict with libgksu0 to the dependencies of gksu.[B

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux
Locale: LANG=en_US.ISO-8859-1, LC_CTYPE=de_DE at euro (charmap=ISO-8859-15)

Versions of packages gksu depends on:
ii  gnome-keyring                0.4.9-1     GNOME keyring services (daemon and
ii  libatk1.0-0                  1.11.4-3    The ATK accessibility toolkit
ii  libc6                        2.3.6-15    GNU C Library: Shared libraries
ii  libcairo2                    1.2.0-3     The Cairo 2D vector graphics libra
ii  libfontconfig1               2.3.2-7     generic font configuration library
ii  libgconf2-4                  2.14.0-1    GNOME configuration database syste
ii  libgksu2-0                   1.9.5-1     library providing su and sudo func
ii  libglib2.0-0                 2.10.3-3    The GLib library of C routines
ii  libgnome-keyring0            0.4.9-1     GNOME keyring services library
ii  libgtk2.0-0                  2.8.18-1    The GTK+ graphical user interface 
ii  liborbit2                    1:2.14.0-2  libraries for ORBit2 - a CORBA ORB
ii  libpango1.0-0                1.12.3-1    Layout and rendering of internatio
ii  libstartup-notification0     0.8-1       library for program launch feedbac
ii  libx11-6                     2:1.0.0-7   X11 client-side library
ii  libxcursor1           X cursor management library
ii  libxext6                     1:1.0.0-4   X11 miscellaneous extension librar
ii  libxfixes3                   1: X11 miscellaneous 'fixes' extensio
ii  libxi6                       1:1.0.0-5   X11 Input extension library
ii  libxinerama1                 1:1.0.1-4   X11 Xinerama extension library
ii  libxrandr2                   2: X11 RandR extension library
ii  libxrender1                  1: X Rendering Extension client libra
ii  sudo                         1.6.8p12-4  Provide limited super user privile

gksu recommends no packages.

-- no debconf information

More information about the Pkg-gnome-maintainers mailing list