Bug#370200: FTBFS: missing libfam.la

Steve Langasek vorlon at debian.org
Sun Jun 4 05:04:00 UTC 2006

reassign 370200 libeel2-dev

On Sun, Jun 04, 2006 at 03:25:00AM +0200, Roberto Pariset wrote:

> nautilus-cd-burner 2.14.1-1 FTBFS with the following error:

> /bin/sh ./libtool --tag=CC --mode=link cc  -Wall -g -Wall -O2  -Wl,-O1 -Wl,--as-needed -o libnautilus-burn-extension.la -rpath /usr/lib/nautilus/extensions-1.0 -avoid-version -module nautilus-burn-bar.lo burn-extension.lo  -pthread -lnautilus-extension -leel-2 -lgnomeui-2 -lSM -lICE -lgailutil -lglade-2.0 -lbonoboui-2 -lgnome-keyring -lgnome-2 -lpopt -lgnomevfs-2 -lbonobo-2 -lgconf-2 -lbonobo-activation -lORBit-2 -lgthread-2.0 -lgnomecanvas-2 -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lxml2 -lz -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXfixes -lpango-1.0 -lcairo -lX11 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   
> grep: /usr/lib/libfam.la: No such file or directory
> /bin/sed: can't read /usr/lib/libfam.la: No such file or directory
> libtool: link: `/usr/lib/libfam.la' is not a valid libtool archive
> make[3]: *** [libnautilus-burn-extension.la] Error 1

> Please let it build depend on libfam-dev.

This error is always caused by some other build-dependency on the system
referencing the named .la file, without depending on the package that
provides it.  In this case, installing the build-deps of nautilus-cd-burner
gives me libeel2-dev as the only .la file with this problem, so reassigning

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon at debian.org                                   http://www.debian.org/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: Digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-gnome-maintainers/attachments/20060603/9fa1f8f7/attachment.pgp

More information about the Pkg-gnome-maintainers mailing list