Bug#388510: libpango1.0-0: Link problem: undefined reference to `g_type_register_static_simple'

Stefan Bellon sbellon at sbellon.de
Sat Sep 23 13:29:48 UTC 2006

On 21 Sep, you wrote:
> On Thu, Sep 21, 2006, Loïc Minier wrote:
> >  Could you try downgrading your pango packages to 1.12.3-2?  (Either
> >  from snapshot.debian.net, or 1.12.3-1+b1 from testing.)

>  Could you also try downgrading glib packages to 2.10 from snapshot?

What's the easiest way of doing this? If I try to downgrade pango1.0
and glib2.0 packages, I get a lot of broken packages related to gnome
and have to remove almost all packages.

On 22 Sep, you wrote:
> On Wed, Sep 20, 2006, Stefan Bellon wrote:
> > When linking something against Gtk (which in turn uses Pango),
> > there's an undefined reference in latest version of libpango1.0-0:
> > /usr/lib/libpangoft2-1.0.so.0: undefined reference to
> > `g_type_register_static_simple'

>  This looks like a locally installed library, please send the output
>  of: ldd /usr/lib/libpangoft2-1.0.so.0

sbellon at io$ ldd /usr/lib/libpangoft2-1.0.so.0
        linux-gate.so.1 =>  (0xffffe000)
        librt.so.1 => /lib/tls/librt.so.1 (0x40037000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x40040000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x40079000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0x400b3000)
        libdl.so.2 => /lib/tls/libdl.so.2 (0x400b6000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x400ba000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x4014c000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40177000)
        libz.so.1 => /usr/lib/libz.so.1 (0x401e1000)
        libm.so.6 => /lib/tls/libm.so.6 (0x401f5000)
        libc.so.6 => /lib/tls/libc.so.6 (0x4021a000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x4034c000)
        /lib/ld-linux.so.2 (0x80000000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x4035f000)

Anything else I could supply?


Stefan Bellon

More information about the Pkg-gnome-maintainers mailing list