Bug#435520: libgtk2.0-0: experimental version breaks many programs (new assertions?)

Johannes Berg johannes at sipsolutions.net
Wed Aug 1 10:38:24 UTC 2007

Package: libgtk2.0-0
Version: 2.11.6-1
Severity: normal

When I upgrade to experimental I get various new assertions like
Gtk-CRITICAL **: gtk_label_set_max_width_chars: assertion `GTK_IS_LABEL
(label)' failed

Gtk-CRITICAL **: gtk_label_set_ellipsize: assertion `GTK_IS_LABEL (label)'  

that break many programs including gossip and epiphany-browser. These never
showed up before; it's well possible that these are genuine bugs in those
programs, in which case I'll go file them there.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.22-ga7008e4e-dirty (PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages libgtk2.0-0 depends on:
(most likely not correct because I'm writing this downgraded to unstable)
ii  libatk1.0-0             1.18.0-2         The ATK accessibility toolkit
ii  libc6                   2.6-5            GNU C Library: Shared libraries
ii  libcairo2               1.4.10-1+b2      The Cairo 2D vector graphics libra
ii  libcupsys2              1.2.12-1         Common UNIX Printing System(tm) - 
ii  libfontconfig1          2.4.2-1.2        generic font configuration library
ii  libglib2.0-0            2.13.7-3         The GLib library of C routines
ii  libgnutls13             1.7.14-1         the GNU TLS library - runtime libr
ii  libgtk2.0-common        2.10.13-1        Common files for the GTK+ graphica
ii  libjpeg62               6b-13            The Independent JPEG Group's JPEG 
ii  libpango1.0-0           1.17.5-1         Layout and rendering of internatio
ii  libpng12-0              1.2.15~beta5-2   PNG library - runtime
ii  libtiff4                3.8.2-7          Tag Image File Format (TIFF) libra
ii  libx11-6                2:1.1.2-1        X11 client-side library
ii  libxcursor1             1:1.1.8-2        X cursor management library
ii  libxext6                1:1.0.3-2        X11 miscellaneous extension librar
ii  libxfixes3              1:4.0.3-2        X11 miscellaneous 'fixes' extensio
ii  libxi6                  2:1.1.1-1        X11 Input extension library
ii  libxinerama1            1:1.0.2-1        X11 Xinerama extension library
ii  libxrandr2              2:1.2.1-1        X11 RandR extension library
ii  libxrender1             1:0.9.2-1        X Rendering Extension client libra
ii  zlib1g                  1: compression library - runtime

Versions of packages libgtk2.0-0 recommends:
ii  hicolor-icon-theme            0.10-1     default fallback theme for FreeDes
ii  libgtk2.0-bin                 2.10.13-1  The programs for the GTK+ graphica

-- no debconf information

More information about the pkg-gnome-maintainers mailing list