Bug#406453: 32bit libgtk2.0 must use /etc/gtk-2.0/gdk-pixbuf.loaders.32

Goswin von Brederlow brederlo at informatik.uni-tuebingen.de
Thu Jan 11 10:36:23 CET 2007

Package: libgtk2.0-0
Version: 2.8.20-3
Severity: grave

When starting a 32bit gtk program on amd64 the libgtk uses the wrong conffile:

open("/etc/gtk-2.0/gdk-pixbuf.loaders", O_RDONLY|O_LARGEFILE) = 4

Subsequently the frong modules are attempted:

(acroread:1689): GdkPixbuf-WARNING **: Error loading XPM image loader: Unable to load image-loading module: /usr/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-xpm.so: /usr/lib/gtk-2.0/2.4.0/loaders/libpixbufloader-xpm.so: cannot open shared object file: No such file or directory) = 277

Replacing /etc/gtk-2.0/gdk-pixbuf.loaders with
/etc/gtk-2.0/gdk-pixbuf.loaders.32 [and fixing the version from 2.10.0
to 2.4.0] fixes the problem for 32bit but obviously breaks 64bit.

The proper fix, and what afaik is supposed to happen, is for the 32bit
libgtk to use /etc/gtk-2.0/gdk-pixbuf.loaders.32 if it exists and the
64bit libgtk to use /etc/gtk-2.0/gdk-pixbuf.loaders.64 if it exists.


PS: I set this to grave as it makes ia32-libs-gtk unusable which
contains libgtk-2.0.

-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-2-amd64
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages libgtk2.0-0 depends on:
ii  libatk1.0-0               1.12.3-1       The ATK accessibility toolkit
ii  libc6                     2.3.6.ds1-9    GNU C Library: Shared libraries
ii  libcairo2                 1.2.4-4        The Cairo 2D vector graphics libra
ii  libfontconfig1            2.4.2-1        generic font configuration library
ii  libglib2.0-0              2.12.4-2       The GLib library of C routines
ii  libgtk2.0-common          2.8.20-3       Common files for the GTK+ graphica
ii  libjpeg62                 6b-13          The Independent JPEG Group's JPEG 
ii  libpango1.0-0             1.14.8-4       Layout and rendering of internatio
ii  libpng12-0                1.2.15~beta5-1 PNG library - runtime
ii  libtiff4                  3.8.2-6        Tag Image File Format (TIFF) libra
ii  libx11-6                  2:1.0.3-4      X11 client-side library
ii  libxcursor1               1.1.7-4        X cursor management library
ii  libxext6                  1:1.0.1-2      X11 miscellaneous extension librar
ii  libxfixes3                1:4.0.1-5      X11 miscellaneous 'fixes' extensio
ii  libxi6                    1:1.0.1-4      X11 Input extension library
ii  libxinerama1              1:1.0.1-4.1    X11 Xinerama extension library
ii  libxrandr2                2:    X11 RandR extension library
ii  libxrender1               1:0.9.1-3      X Rendering Extension client libra

Versions of packages libgtk2.0-0 recommends:
ii  hicolor-icon-theme            0.8-4      default fallback theme for FreeDes
pn  libgtk2.0-bin                 <none>     (no description available)

-- no debconf information

More information about the Pkg-gnome-maintainers mailing list