Bug#407813: python-gnome2-desktop: package does not include gnomedesktop module

Christopher Allan Webber cwebber at dustycloud.org
Sun Jan 21 16:38:07 CET 2007

Package: python-gnome2-desktop
Version: 2.14.0-3
Severity: normal

I have been trying to get the latest version of Gimmie to run

I am able to get it to compile, but it won't run because

ImportError: No module named gnomedesktop

I have python-gnome2-desktop and python-gnome2-desktop-dev
installed... I would think these would be what should provide the
gnomedesktop module, but apparently they do not.  If these don't, what

(Apparently the module is considered standard enough now so that Alex
Gravely, the Gimmie developer, said in the changelog:

	Remove egg, wnck, gnomedesktop, since most people have these
	now, and the bugs have been fixed (I hope).

-- System Information:
Debian Release: 4.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-1-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages python-gnome2-desktop depends on:
ii  libart-2.0-2               2.3.17-1      Library of functions for 2D graphi
ii  libatk1.0-0                1.12.4-1      The ATK accessibility toolkit
ii  libbonobo2-0               2.14.0-3      Bonobo CORBA interfaces library
ii  libbonoboui2-0             2.14.0-5      The Bonobo UI library
ii  libc6                      2.3.6.ds1-10  GNU C Library: Shared libraries
ii  libcairo2                  1.2.4-4       The Cairo 2D vector graphics libra
ii  libfontconfig1             2.4.2-1       generic font configuration library
ii  libgconf2-4                2.16.0-3      GNOME configuration database syste
ii  libglade2-0                1:2.6.0-4     library to load .glade files at ru
ii  libglib2.0-0               2.12.6-2      The GLib library of C routines
ii  libgnome-keyring0          0.6.0-3       GNOME keyring services library
ii  libgnome-media0            2.14.2-4      runtime libraries for the GNOME me
ii  libgnome2-0                2.16.0-2      The GNOME 2 library - runtime file
ii  libgnomecanvas2-0          2.14.0-2      A powerful object-oriented display
ii  libgnomeprint2.2-0         2.12.1-7      The GNOME 2.2 print architecture -
ii  libgnomeprintui2.2-0       2.12.1-4      GNOME 2.2 print architecture User 
ii  libgnomeui-0               2.14.1-2      The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0             2.14.2-4      GNOME virtual file-system (runtime
ii  libgtk2.0-0                2.8.20-4      The GTK+ graphical user interface 
ii  libgtksourceview1.0-0      1.8.3-1       shared libraries for the GTK+ synt
ii  libgtop2-7                 2.14.4-2      gtop system monitoring library
ii  libice6                    1:1.0.1-2     X11 Inter-Client Exchange library
ii  libmetacity0               1:2.14.5-2    library of lightweight GTK2 based 
ii  libnautilus-burn3          2.14.3-8      Nautilus Burn Library - runtime ve
ii  liborbit2                  1:2.14.4-1    libraries for ORBit2 - a CORBA ORB
ii  libpanel-applet2-0         2.14.3-4      library for GNOME 2 panel applets
ii  libpango1.0-0              1.14.8-4      Layout and rendering of internatio
ii  libpopt0                   1.10-3        lib for parsing cmdline parameters
ii  libsm6                     1:1.0.1-3     X11 Session Management library
ii  libtotem-plparser1         2.16.4-2      Totem Playlist Parser library - ru
ii  libwnck18                  2.14.3-1      Window Navigator Construction Kit 
ii  libx11-6                   2:1.0.3-4     X11 client-side library
ii  libxcursor1                1.1.7-4       X cursor management library
ii  libxext6                   1:1.0.1-2     X11 miscellaneous extension librar
ii  libxfixes3                 1:4.0.1-5     X11 miscellaneous 'fixes' extensio
ii  libxi6                     1:1.0.1-4     X11 Input extension library
ii  libxinerama1               1:1.0.1-4.1   X11 Xinerama extension library
ii  libxml2                    2.6.27.dfsg-1 GNOME XML library
ii  libxrandr2                 2:   X11 RandR extension library
ii  libxrender1                1:0.9.1-3     X Rendering Extension client libra
ii  python                     2.4.4-2       An interactive high-level object-o
ii  python-central             0.5.12        register and build utility for Pyt
ii  python-gtk2                2.8.6-8       Python bindings for the GTK+ widge
ii  python-pyorbit             2.0.1-5       A Python language binding for the 
ii  zlib1g                     1:1.2.3-13    compression library - runtime

python-gnome2-desktop recommends no packages.

-- no debconf information

More information about the Pkg-gnome-maintainers mailing list