Bug#425323: totem-gstreamer: Cannot load subtitles

Javier Kohen jkohen at users.sourceforge.net
Sun May 20 21:55:18 UTC 2007

Package: totem-gstreamer
Version: 2.18.1-1
Severity: normal

Hash: SHA1

Attempting to play a movie with subtitles when using the gstreamer backend gives the following error on the console and the movie won't play.

** Message: Error: Internal data flow error.
gstbasesrc.c(1642): gst_base_src_loop (): /play/subtitle-bin/filesrc0:
streaming task paused, reason not-linked (-1)

Moving the subtitles away allows one to watch the movie.

I tried three different formats of subtitles for the same movie but none of them worked. The same release of totem-xine can load and display the subtitles with no problems.

- -- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux
Locale: LANG=es_AR.UTF-8, LC_CTYPE=es_AR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages totem-gstreamer depends on:
ii  gconf2               GNOME configuration database syste
ii  gnome-icon-theme        2.18.0-2         GNOME Desktop icon theme
ii  gstreamer0.10-alsa [gst 0.10.12-2        GStreamer plugin for ALSA
ii  gstreamer0.10-gnomevfs  0.10.12-2        GStreamer plugin for GnomeVFS
ii  gstreamer0.10-plugins-b 0.10.12-2        GStreamer plugins from the "base" 
ii  gstreamer0.10-plugins-g 0.10.5-5         GStreamer plugins from the "good" 
ii  gstreamer0.10-x         0.10.12-2        GStreamer plugins for X11 and Pang
ii  libart-2.0-2            2.3.19-3         Library of functions for 2D graphi
ii  libatk1.0-0             1.18.0-2         The ATK accessibility toolkit
ii  libaudiofile0           0.2.6-6          Open-source version of SGI's audio
ii  libavahi-client3        0.6.19-2         Avahi client library
ii  libavahi-common3        0.6.19-2         Avahi common library
ii  libavahi-glib1          0.6.19-2         Avahi glib integration library
ii  libbonobo2-0            2.18.0-2         Bonobo CORBA interfaces library
ii  libbonoboui2-0          2.18.0-5         The Bonobo UI library
ii  libc6                   2.5-7            GNU C Library: Shared libraries
ii  libcairo2               1.4.6-1          The Cairo 2D vector graphics libra
ii  libdbus-1-3             1.0.2-5          simple interprocess messaging syst
ii  libdbus-glib-1-2        0.73-2           simple interprocess messaging syst
ii  libesd-alsa0 [libesd0]  0.2.36-3         Enlightened Sound Daemon (ALSA) - 
ii  libfontconfig1          2.4.2-1.2        generic font configuration library
ii  libfreetype6            2.2.1-5          FreeType 2 font engine, shared lib
ii  libgcc1                 1:4.2-20070516-1 GCC support library
ii  libgconf2-4          GNOME configuration database syste
ii  libgcrypt11             1.2.4-2          LGPL Crypto library - runtime libr
ii  libglade2-0             1:2.6.0-4        library to load .glade files at ru
ii  libglib2.0-0            2.12.12-1        The GLib library of C routines
ii  libgnome-desktop-2      2.18.1-1         Utility library for loading .deskt
ii  libgnome-keyring0       0.8.1-2          GNOME keyring services library
ii  libgnome2-0             2.18.0-4         The GNOME 2 library - runtime file
ii  libgnomecanvas2-0       2.14.0-2         A powerful object-oriented display
ii  libgnomeui-0            2.18.1-2         The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0          1:2.18.1-2       GNOME Virtual File System (runtime
ii  libgnutls13             1.6.2-2          the GNU TLS library - runtime libr
ii  libgpg-error0           1.4-2            library for common error values an
ii  libgstreamer-plugins-ba 0.10.12-2        GStreamer libraries from the "base
ii  libgstreamer0.10-0      0.10.12-5        Core GStreamer libraries and eleme
ii  libgtk2.0-0             2.10.12-2        The GTK+ graphical user interface 
ii  libhal1                 0.5.9-2          Hardware Abstraction Layer - share
hi  libice6                 1:1.0.3-2        X11 Inter-Client Exchange library
ii  libjpeg62               6b-13            The Independent JPEG Group's JPEG 
ii  liblircclient0          0.8.0-9.2        LIRC client library
ii  libnautilus-extension1  2.18.1-2         libraries for nautilus components 
ii  liborbit2               1:2.14.7-0.1     libraries for ORBit2 - a CORBA ORB
ii  libpango1.0-0           1.16.4-1         Layout and rendering of internatio
ii  libpng12-0              1.2.15~beta5-2   PNG library - runtime
ii  libpopt0                1.10-3           lib for parsing cmdline parameters
hi  libsm6                  2:1.0.3-1        X11 Session Management library
ii  libstartup-notification 0.9-1            library for program launch feedbac
ii  libstdc++6              4.2-20070516-1   The GNU Standard C++ Library v3
ii  libtasn1-3              0.3.9-1          Manage ASN.1 structures (runtime)
ii  libtotem-plparser1      2.18.1-1         Totem Playlist Parser library - ru
hi  libx11-6                2:1.0.3-7        X11 client-side library
ii  libxcursor1             1:1.1.8-2        X cursor management library
ii  libxext6                1:1.0.3-2        X11 miscellaneous extension librar
ii  libxfixes3              1:4.0.3-2        X11 miscellaneous 'fixes' extensio
ii  libxi6                  1:1.0.1-4        X11 Input extension library
ii  libxinerama1            1:1.0.2-1        X11 Xinerama extension library
ii  libxml2                 2.6.28.dfsg-1    GNOME XML library
ii  libxrandr2              2:1.2.1-1        X11 RandR extension library
ii  libxrender1             1:0.9.2-1        X Rendering Extension client libra
ii  libxtst6                1:1.0.1-5        X11 Testing -- Resource extension 
ii  zlib1g                  1:1.2.3-15       compression library - runtime

Versions of packages totem-gstreamer recommends:
ii  gnome-control-center          1:2.18.1-1 utilities to configure the GNOME d
ii  gstreamer0.10-ffmpeg          0.10.2-2   FFmpeg plugin for GStreamer
ii  gstreamer0.10-plugins-ugly    0.10.5-2   GStreamer plugins from the "ugly" 
ii  totem-mozilla                 2.18.1-1   Totem Mozilla plugin

- -- no debconf information

Version: GnuPG v1.4.6 (GNU/Linux)


More information about the pkg-gnome-maintainers mailing list