Bug#445947: Quotes in gdm.conf break configuration after upgrade

Javier Kohen jkohen at users.sourceforge.net
Tue Oct 9 09:40:12 UTC 2007

Package: gdm
Version: 2.20.0-2
Severity: important

Hash: SHA1

After upgrading to this version I noticed that GDM was failing to restart. The culprit was a configuration line in the servers section of gdm.conf. The previous version of gdmsetup had created the following entry:
0=Standard -layout \"Single LVDS\"

However, the latest version of GDM was choking on the space. Removing the backslashes before the quotes solved the issue.

I set the severity to important because this breaks perfectly working setups created with the bundled configuration utility. The manual fix is trivial, though.

I don't know whether the latest version of gdmsetup writes the backslashes or not.

- -- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux
Locale: LANG=es_AR.UTF-8, LC_CTYPE=es_AR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gdm depends on:
ii  adduser                    3.105         add and remove users and groups
ii  debconf [debconf-2.0]      1.5.14        Debian configuration management sy
ii  gksu                       2.0.0-4       graphical frontend to su
ii  gnome-session              2.20.0-1      The GNOME 2 Session Manager
ii  gnome-terminal [x-terminal 2.18.2-1      The GNOME 2 terminal emulator appl
ii  libart-2.0-2               2.3.19-3      Library of functions for 2D graphi
ii  libatk1.0-0                1.20.0-1      The ATK accessibility toolkit
ii  libattr1                   1:2.4.39-1    Extended attribute shared library
ii  libc6                      2.6.1-3       GNU C Library: Shared libraries
ii  libcairo2                  1.4.10-1      The Cairo 2D vector graphics libra
ii  libdbus-1-3                1.1.1-3       simple interprocess messaging syst
ii  libdbus-glib-1-2           0.74-1        simple interprocess messaging syst
ii  libdmx1                    1:1.0.2-2     X11 Distributed Multihead extensio
ii  libfontconfig1             2.4.2-1.2     generic font configuration library
ii  libglade2-0                1:2.6.2-1     library to load .glade files at ru
ii  libglib2.0-0               2.14.1-2      The GLib library of C routines
ii  libgnomecanvas2-0          2.20.0-1      A powerful object-oriented display
ii  libgtk2.0-0                2.12.0-2      The GTK+ graphical user interface 
ii  libpam-modules       Pluggable Authentication Modules f
ii  libpam-runtime       Runtime support for the PAM librar
ii  libpam0g             Pluggable Authentication Modules l
ii  libpango1.0-0              1.18.2-1      Layout and rendering of internatio
ii  librsvg2-2                 2.18.2-1      SAX-based renderer library for SVG
ii  librsvg2-common            2.18.2-1      SAX-based renderer library for SVG
ii  libselinux1                2.0.15-2+b1   SELinux shared libraries
ii  libwrap0                   7.6.dbs-14    Wietse Venema's TCP wrappers libra
hi  libx11-6                   2:1.0.3-7     X11 client-side library
ii  libxau6                    1:1.0.3-2     X11 authorisation library
ii  libxcomposite1             1:0.3.2-1+b1  X11 Composite extension library
ii  libxcursor1                1:1.1.9-1     X cursor management library
ii  libxdamage1                1:1.1.1-3     X11 damaged region extension libra
hi  libxdmcp6                  1:1.0.2-2     X11 Display Manager Control Protoc
ii  libxext6                   1:1.0.3-2     X11 miscellaneous extension librar
ii  libxfixes3                 1:4.0.3-2     X11 miscellaneous 'fixes' extensio
ii  libxi6                     2:1.1.3-1     X11 Input extension library
ii  libxinerama1               1:1.0.2-1     X11 Xinerama extension library
ii  libxml2                    2.6.30.dfsg-2 GNOME XML library
ii  libxrandr2                 2:1.2.2-1     X11 RandR extension library
ii  libxrender1                1:0.9.4-1     X Rendering Extension client libra
ii  lsb-base                   3.1-24        Linux Standard Base 3.1 init scrip
ii  metacity [x-window-manager 1:2.20.0-1    A lightweight GTK2 based Window Ma
ii  xbase-clients              1:7.3+2       miscellaneous X clients - metapack
ii  xterm [x-terminal-emulator 229-1         X terminal emulator

Versions of packages gdm recommends:
ii  dialog                    1.1-20070604-1 Displays user-friendly dialog boxe
ii  gdm-themes                0.5.1          Themes for the GNOME Display Manag
pn  xserver-xephyr | xnest    <none>         (no description available)
ii  xserver-xorg              1:7.3+2        the X.Org X server
ii  zenity                    2.20.0-2       Display graphical dialog boxes fro

- -- debconf information:
  gdm/daemon_name: /usr/bin/gdm
* shared/default-x-display-manager: gdm

Version: GnuPG v1.4.6 (GNU/Linux)


More information about the pkg-gnome-maintainers mailing list