Bug#475488: libglib2.0-dev: incompatible pointer type warning on ia64

Bryan Sutula Bryan.Sutula at hp.com
Fri Apr 11 01:14:39 UTC 2008

Package: libglib2.0-dev
Version: 2.16.2-1
Severity: normal

A simple test program using GStaticMutex and g_static_mutex_lock()
produces a warning on ia64, but not on i386 or amd64.  It appears that
upstream glib did a clean-up change before 2.16.2, which now causes
warnings on some platforms.

The test program I used is:

#include <stdlib.h>
#include <glib.h>

GStaticMutex my_mutex = G_STATIC_MUTEX_INIT;

int     main(void) {

        g_static_mutex_lock(& my_mutex);
        g_static_mutex_unlock(& my_mutex);


The compile command and output is:

cc `pkg-config --cflags --libs glib-2.0`    x.c   -o x
x.c: In function 'main':
x.c:8: warning: passing argument 1 of 'g_atomic_pointer_get' from incompatible pointer type
x.c:9: warning: passing argument 1 of 'g_atomic_pointer_get' from incompatible pointer type

Again, this is only on ia64, as far as I've been able to try, but may
be on other platforms.  The warning can cause FTBFS on other packages
using glib, if that package uses -Werror.

The following URL has a decent description of the problem.  The first
post is a similar problem statement, and the final post explains what
may be wrong in glib.


-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable')
Architecture: ia64

Kernel: Linux 2.6.18-6-mckinley (SMP w/2 CPU cores)
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages libglib2.0-dev depends on:
ii  libc6.1                       2.7-10     GNU C Library: Shared libraries
ii  libglib2.0-0                  2.16.2-1   The GLib library of C routines
ii  libpcre3                      7.6-2      Perl 5 Compatible Regular Expressi
ii  libselinux1                   2.0.59-1   SELinux shared libraries
ii  pkg-config                    0.22-1     manage compile and link flags for 

Versions of packages libglib2.0-dev recommends:
ii  python                        2.4.4-6    An interactive high-level object-o

-- no debconf information

More information about the pkg-gnome-maintainers mailing list