Bug#450832: drivemount: exact same behaviour

Dariusz Szczepanek szczepanek_d at wp.pl
Mon Jan 28 14:18:46 UTC 2008

Package: gnome-applets
Version: 2.20.1-2
Followup-For: Bug #450832

drivemount-applet behaves similarly on my system. It appears on the
process list but isn't visible on the panel. When i kill it, a dialog
box appears about the applet quitting unexpectedly. Then I still can't
add it to the panel or launch it from the console either. I have found
this in .xsession-errors:

(gnome-panel:5385): Gtk-WARNING **: gtk_widget_size_allocate(): attempt
to allocate widget with width -9 and height 24

....although I'm not sure if it's connected to drivemount. And I've no
idea where the -9 value is coming from. I searched the gnome
configuration editor for this or anything relevant to drivemount but
came out empty.


-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.23
Locale: LANG=en_US, LC_CTYPE=pl_PL (charmap=ISO-8859-2)
Shell: /bin/sh linked to /bin/bash

Versions of packages gnome-applets depends on:
ii  debconf [debconf-2.0]    1.5.18          Debian configuration management sy
ii  gconf2                   2.20.1-2+b1     GNOME configuration database syste
ii  gnome-applets-data       2.20.1-2        Various applets for GNOME 2 panel 
ii  gnome-icon-theme         2.20.0-1        GNOME Desktop icon theme
ii  gnome-panel              2.20.3-1        launcher and docking facility for 
ii  gstreamer0.10-alsa       0.10.15-4       GStreamer plugin for ALSA
ii  gstreamer0.10-plugins-go 0.10.6-4        GStreamer plugins from the "good" 
ii  libapm1                  3.2.2-8.1       Library for interacting with APM d
ii  libatk1.0-0              1.20.0-1        The ATK accessibility toolkit
ii  libbonoboui2-0           2.20.0-1        The Bonobo UI library
ii  libc6                    2.7-6           GNU C Library: Shared libraries
ii  libcpufreq0              002-7           shared library to deal with the cp
ii  libdbus-1-3              1.1.2-1         simple interprocess messaging syst
ii  libdbus-glib-1-2         0.74-1          simple interprocess messaging syst
ii  libgconf2-4              2.20.1-2+b1     GNOME configuration database syste
ii  libglade2-0              1:2.6.2-1       library to load .glade files at ru
ii  libglib2.0-0             2.14.5-2        The GLib library of C routines
ii  libgnome-desktop-2       2.20.3-1        Utility library for loading .deskt
ii  libgnome2-0          The GNOME 2 library - runtime file
ii  libgnomekbd1             2.20.0-1        GNOME library to manage keyboard c
ii  libgnomekbdui1           2.20.0-1        User interface library for libgnom
ii  libgnomeui-0         The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0           1:2.20.1-1      GNOME Virtual File System (runtime
ii  libgnomevfs2-extra       1:2.20.1-1      GNOME Virtual File System (extra m
ii  libgstreamer-plugins-bas 0.10.15-4       GStreamer libraries from the "base
ii  libgstreamer0.10-0       0.10.15-4       Core GStreamer libraries and eleme
ii  libgtk2.0-0              2.12.5-2        The GTK+ graphical user interface 
ii  libgtop2-7               2.20.1-1        gtop system monitoring library
ii  libgucharmap6            1:1.10.2-1      Unicode browser widget library (sh
ii  libhal1                  0.5.10-5        Hardware Abstraction Layer - share
ii  libnotify1 [libnotify1-g 0.4.4-3         sends desktop notifications to a n
ii  liboobs-1-3              2.20.0-1        GObject based interface to system-
ii  libpanel-applet2-0       2.20.3-1        library for GNOME Panel applets
ii  libpango1.0-0            1.18.4-1        Layout and rendering of internatio
ii  libwnck22                2.20.3-1        Window Navigator Construction Kit 
ii  libx11-6                 2:1.0.3-7       X11 client-side library
ii  libxklavier11            3.3-2           X Keyboard Extension high-level AP
ii  libxml2                  2.6.30.dfsg-3.1 GNOME XML library
ii  python                   2.4.4-6         An interactive high-level object-o

Versions of packages gnome-applets recommends:
pn  deskbar-applet         <none>            (no description available)
ii  gnome-media            2.20.1-3          GNOME media utilities
pn  gnome-netstatus-applet <none>            (no description available)
ii  gnome-system-monitor   2.20.2-1          Process viewer and system resource
ii  imagemagick            7: Image manipulation programs
ii  python-gnome2          2.20.1-2          Python bindings for the GNOME desk

-- debconf information:
  gnome-applets/cpufreq_SUID_bit: false

More information about the pkg-gnome-maintainers mailing list