Bug#429422: libgnomekbdui2: The crash happens with non-UTF8 locales

Alberto Garcia berto at elpiso.org
Thu Jun 12 20:35:34 UTC 2008

Package: libgnomekbdui2
Version: 2.22.0-1
Followup-For: Bug #429422

I think that the bug is in libgnomekbd and it happens if you have a
non-UTF8 locale, at least that's the way I reproduce it.

I have already sent a more detailed bug report to the GNOME bugzilla,
but no one has taken care of it so far:


If I set my locate to UTF-8 (export LC_ALL=pt_PT.UTF-8) and then
restart the gnome-screensaver then the problem disappears:

$ gnome-screensaver-command --exit
$ gnome-screensaver

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=pt_PT, LC_CTYPE=pt_PT (charmap=ISO-8859-15) (ignored: LC_ALL set to pt_PT at euro)
Shell: /bin/sh linked to /bin/dash

Versions of packages libgnomekbdui2 depends on:
ii  libatk1.0-0                1.22.0-1      The ATK accessibility toolkit
ii  libc6                      2.7-10        GNU C Library: Shared libraries
ii  libcairo2                  1.6.4-1+b1    The Cairo 2D vector graphics libra
ii  libdbus-1-3                1.2.1-2       simple interprocess messaging syst
ii  libdbus-glib-1-2           0.74-4        simple interprocess messaging syst
ii  libgconf2-4                2.22.0-1      GNOME configuration database syste
ii  libglib2.0-0               2.16.3-2      The GLib library of C routines
ii  libgnomekbd2               2.22.0-1      GNOME library to manage keyboard c
ii  libgtk2.0-0                2.12.9-3      The GTK+ graphical user interface 
ii  libpango1.0-0              1.20.2-2      Layout and rendering of internatio
ii  libx11-6                   2:1.0.3-7     X11 client-side library
ii  libxklavier12              3.5-1         X Keyboard Extension high-level AP
ii  libxml2                    2.6.32.dfsg-2 GNOME XML library

libgnomekbdui2 recommends no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list