Bug#470741: epiphany doesn't start anymore, mozembed incompability?

Erich Schubert erich at debian.org
Thu Mar 13 10:51:12 UTC 2008

Package: epiphany-browser
Version: 2.21.90-1
Severity: serious

Since today, epiphany-browser (experimental!) doesn't start anymore:

sys:1: Warning: /tmp/buildd/glib2.0-2.16.1/gobject/gsignal.c:1669: signal `ge-content-change' is invalid for instance `0x8dba8b8'
sys:1: Warning: /tmp/buildd/glib2.0-2.16.1/gobject/gsignal.c:1669: signal `new-document-now' is invalid for instance `0x8dba8b8'
sys:1: Warning: invalid cast from `MozillaEmbed' to `GtkMozEmbed'

** (epiphany-browser:10341): CRITICAL **: void gtk_moz_embed_get_nsIWebBrowser(GtkMozEmbed*, nsIWebBrowser**): assertion `GTK_IS_MOZ_EMBED(embed)' failed
epiphany-browser: symbol lookup error: epiphany-browser: undefined symbol: g_uri_get_scheme

Since that looks like the API of GtkMozEmbed has changed I don't expect the 'unstable' Version to work better, but I will try downgrading now.

--- System information. ---
Architecture: i386
Kernel:       Linux 2.6.24-1-686

Debian Release: lenny/sid
  500 unstable        www.debian-multimedia.org 
  500 unstable        ftp.de.debian.org 
    1 experimental    ftp.de.debian.org 

--- Package information. ---
Depends              (Version) | Installed
epiphany-gecko                 | 2.21.90-1
 OR epiphany-webkit            | 2.21.90-1

best regards,
Erich Schubert
     erich@(vitavonni.de|debian.org)    --    GPG Key ID: 4B3A135C    (o_
 Why waste time learning, when ignorance is instantaneous? --- Calvin //\
                   Großen Herren und schönen Frauen                   V_/_
       Soll man gern dienen, wenig trauen. --- Georg Rollenhagen

More information about the pkg-gnome-maintainers mailing list