Bug#451203: gnome-applets: correction and more information from more tests

Sven Arvidsson sa at whiz.se
Sat May 10 17:04:12 UTC 2008


Can you please add this to the upstream bug report at

I could add it for you, but it's a lot easier if you take part in the
upstream discussion directly, as I have no way of reproducing the

On Sat, 2008-05-10 at 04:00 +0200, A B wrote:
> Package: gnome-applets
> Version: 2.20.1-3
> Followup-For: Bug #451203
> Hello again,
> I did more testings, including with an other card (usb-audio, usb code
> 046d:0a01, it's a Headset sound card type from Logitech).
> Sadly I have to correct my previous report. Altough I didn't notice it,
> I also get volume problems with the 2.14.3-4, it will just never display
> the volume as a false mute.
> Still on hda-intel the behavior on 2.14.3-4 is like this:
> Randomly, when changing the master volume (and checking with an alsamixer also 
> running), the left volume channel drops to zero, while the right volume
> stays correct. On the next change, the two channels are averaged. So after
> some up key I got 75% -> 79% but the left channel dropped to zero in
> alsamixer. Then I decreased it, the new value was 35% (79/2 -4)
> for the two channels. Actual values from test.
> With 2.20.1-3, the behavior is a bit different, I never see the left channel
> dropping to zero, but about the same happens.
> One test: I did up with 28% and it dropped to 16%. I can assume it's
> increased first and then divided by 2 ((28+4)/2). Other try: 59% up, I get
> 31% ((59+4)/2). There's also the random false mute display, but I can't
> find it linked with when the volume gets wrong.
> Now with the usb-audio card it's worse. I have to use the "Speaker"
> control because there's no master. It gets wrong at almost each use.
> It can take several seconds keeping the up key repeating before reaching
> 100%. Even if sometimes it works fine for some time, it's almost
> impossible to set it correctly with the mixer_applet2, while as usual it's
> always working fine with alsamixer. Sadly the usb-audio doesn't appear
> to have an OSS emulation API.
> I can also notice that if I change the volume on alsamixer, the
> (2.20.1-3) mixer_applet2 also randomly shows the false mute.
> Other interesting info, but it's no more with mixer_applet2: if I run
> gnome-volume-control (which behaves as bad as mixer_applet2) and change
> the sound on alsamixer, the bug appears.  gnome-volume-control, by just
> being around makes the sound control unstable even if changing its settings
> with alsamixer.
> Debug should be done with a usb-audio card, much more interesting samples.
> regards,
> A.B.
> -- System Information:
> -- System Information:
> Debian Release: lenny/sid
>   APT prefers testing
>   APT policy: (600, 'testing'), (50, 'unstable'), (10, 'stable')
> Architecture: i386 (i686)
> Kernel: Linux 2.6.25-1-strider (SMP w/2 CPU cores; PREEMPT)
> Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
> Shell: /bin/sh linked to /bin/bash
> Versions of packages gnome-applets depends on:
> ii  debconf [debconf-2.0]      1.5.21        Debian configuration management sy
> ii  gconf2                     2.22.0-1      GNOME configuration database syste
> ii  gnome-applets-data         2.20.1-3      Various applets for GNOME 2 panel 
> ii  gnome-icon-theme           2.22.0-1      GNOME Desktop icon theme
> ii  gnome-panel                2.20.3-3      launcher and docking facility for 
> ii  gstreamer0.10-alsa         0.10.19-1     GStreamer plugin for ALSA
> ii  gstreamer0.10-plugins-good 0.10.7-3      GStreamer plugins from the "good" 
> ii  libapm1                    3.2.2-10      Library for interacting with APM d
> ii  libatk1.0-0                1.22.0-1      The ATK accessibility toolkit
> ii  libbonoboui2-0             2.22.0-1      The Bonobo UI library
> ii  libc6                      2.7-10        GNU C Library: Shared libraries
> ii  libcpufreq0                002-7.2       shared library to deal with the cp
> ii  libdbus-1-3                1.2.1-2       simple interprocess messaging syst
> ii  libdbus-glib-1-2           0.74-2        simple interprocess messaging syst
> ii  libgconf2-4                2.22.0-1      GNOME configuration database syste
> ii  libglade2-0                1:2.6.2-1     library to load .glade files at ru
> ii  libglib2.0-0               2.16.1-2      The GLib library of C routines
> ii  libgnome-desktop-2         2.22.1-1      Utility library for loading .deskt
> ii  libgnome2-0          The GNOME 2 library - runtime file
> ii  libgnomekbd2               2.22.0-1      GNOME library to manage keyboard c
> ii  libgnomekbdui2             2.22.0-1      User interface library for libgnom
> ii  libgnomeui-0         The GNOME 2 libraries (User Interf
> ii  libgnomevfs2-0             1:2.22.0-2    GNOME Virtual File System (runtime
> ii  libgnomevfs2-extra         1:2.22.0-2    GNOME Virtual File System (extra m
> ii  libgstreamer-plugins-base0 0.10.19-1     GStreamer libraries from the "base
> ii  libgstreamer0.10-0         0.10.19-3     Core GStreamer libraries and eleme
> ii  libgtk2.0-0                2.12.9-2      The GTK+ graphical user interface 
> ii  libgtop2-7                 2.22.1-1      gtop system monitoring library
> ii  libgucharmap6              1:2.22.1-1    Unicode browser widget library (sh
> ii  libhal1                    0.5.11~rc2-1  Hardware Abstraction Layer - share
> ii  libnotify1 [libnotify1-gtk 0.4.4-3       sends desktop notifications to a n
> ii  liboobs-1-3                2.20.0-1      GObject based interface to system-
> ii  libpanel-applet2-0         2.20.3-3      library for GNOME Panel applets
> ii  libpango1.0-0              1.20.2-2      Layout and rendering of internatio
> ii  libwnck22                  2.22.1-1      Window Navigator Construction Kit 
> ii  libx11-6                   2:1.0.3-7     X11 client-side library
> ii  libxklavier12              3.5-1         X Keyboard Extension high-level AP
> ii  libxml2                    2.6.32.dfsg-2 GNOME XML library
> ii  python                     2.5.2-1       An interactive high-level object-o
> Versions of packages gnome-applets recommends:
> pn  deskbar-applet                <none>     (no description available)
> ii  gnome-media                   2.22.0-1   GNOME media utilities
> pn  gnome-netstatus-applet        <none>     (no description available)
> pn  gnome-system-monitor          <none>     (no description available)
> ii  python-gnome2                 2.22.0-1   Python bindings for the GNOME desk
> -- debconf information excluded
> _______________________________________________
> pkg-gnome-maintainers mailing list
> pkg-gnome-maintainers at lists.alioth.debian.org
> http://lists.alioth.debian.org/mailman/listinfo/pkg-gnome-maintainers
Sven Arvidsson
PGP Key ID 760BDD22
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.alioth.debian.org/pipermail/pkg-gnome-maintainers/attachments/20080510/7dfaf52d/attachment.pgp 

More information about the pkg-gnome-maintainers mailing list