Bug#483560: Unable to load image-loading modules

Loïc Minier lool at dooz.org
Fri May 30 09:15:27 UTC 2008

On Fri, May 30, 2008, Ted Percival wrote:
> I looked around and found /etc/gtk-2.0/gdk-pixbuf.loaders which is  
> probably the cause of this. It is attached.


# versions prior to 2.10.1-1 used the 2.4.0 binary version and generated module
# files below /etc/gtk-2.0 which will we can not leave behind (since they
# reference modules not on the system anymore)
if [ "$1" = "configure" ] && dpkg --compare-versions "$2" lt "2.10.3-2"; then
    echo "Removing generated module files coming from the previous Gtk binary version..."
    rm -v -f /etc/gtk-2.0/gdk-pixbuf.loaders
    rm -v -f /etc/gtk-2.0/gtk.immodules

 Perhaps Gtk+ was borken on your system for some reason.

 Or perhaps you got /etc/gtk-2.0/gdk-pixbuf.loaders from some other
 package or by running some other command?

 Anyway, I doubt this is due to the current Debian Gtk+.

Loïc Minier

More information about the pkg-gnome-maintainers mailing list