Bug#502392: update-notifier: refuses to start if the admin group exists

Arthur de Jong arthur at west.nl
Thu Oct 16 08:07:13 UTC 2008

Subject: update-notifier: refuses to start if the admin group exists
Package: update-notifier
Version: 0.70.7.debian-4
Severity: normal

On my system update-notifier refuses to start with the message:

* (update-notifier:12663): WARNING **: not starting because user is not in admin group

In our environment we have an admin group that is used for
administrative staff (not system administrators).

It took me quite a while to figure out what was going on and how to fix
it (not documented in /usr/share/doc or the manual page). It turns out
you should use the --force option in this situation.

Please don't use a normal group name that is not a default system group
(perhaps the adm or operator group should be used instead if it contains
any members) or provide some other means for administrators to hide
update-notifier for users that shouldn't be made aware of updates.

Also, please document this mechanism (and the --force option) in the
manual page. (I found it when I was looking at the source)

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_GB (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages update-notifier depends on:
ii  dbus [dbus-1-utils]      1.2.1-3         simple interprocess messaging syst
ii  gksu                     2.0.0-5         graphical frontend to su
ii  hal                      0.5.11-3        Hardware Abstraction Layer
ii  libart-2.0-2             2.3.20-2        Library of functions for 2D graphi
ii  libatk1.0-0              1.22.0-1        The ATK accessibility toolkit
ii  libbonobo2-0             2.22.0-1        Bonobo CORBA interfaces library
ii  libbonoboui2-0           2.22.0-1        The Bonobo UI library
ii  libc6                    2.7-14          GNU C Library: Shared libraries
ii  libcairo2                1.6.4-6         The Cairo 2D vector graphics libra
ii  libdbus-1-3              1.2.1-3         simple interprocess messaging syst
ii  libdbus-glib-1-2         0.76-1          simple interprocess messaging syst
ii  libgconf2-4              2.22.0-1        GNOME configuration database syste
ii  libglade2-0              1:2.6.2-1       library to load .glade files at ru
ii  libglib2.0-0             2.16.6-1        The GLib library of C routines
ii  libgnome2-0          The GNOME 2 library - runtime file
ii  libgnomecanvas2-0      A powerful object-oriented display
ii  libgnomeui-0         The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0           1:2.22.0-5      GNOME Virtual File System (runtime
ii  libgtk2.0-0              2.12.11-3       The GTK+ graphical user interface 
ii  libhal1                  0.5.11-3        Hardware Abstraction Layer - share
ii  libice6                  2:1.0.4-1       X11 Inter-Client Exchange library
ii  libnotify1 [libnotify1-g 0.4.4-3         sends desktop notifications to a n
ii  liborbit2                1:2.14.13-0.1   libraries for ORBit2 - a CORBA ORB
ii  libpango1.0-0            1.20.5-2        Layout and rendering of internatio
ii  libpopt0                 1.14-4          lib for parsing cmdline parameters
ii  libsm6                   2:1.0.3-2       X11 Session Management library
ii  libx11-6                 2:1.1.5-2       X11 client-side library
ii  libxml2                  2.6.32.dfsg-4   GNOME XML library
ii  notification-daemon      0.3.7-1+b1      a daemon that displays passive pop
ii  python                   2.5.2-2         An interactive high-level object-o
ii  python-apt              Python interface to libapt-pkg
ii  update-manager           0.68.debian-6   GNOME application that manages sof
ii  update-notifier-common   0.70.7.debian-4 Files shared between update-notifi

-- arthur de jong - arthur at west.nl - west consulting b.v. --

More information about the pkg-gnome-maintainers mailing list