Bug#523590: /usr/bin/gnome-system-log: shouldn't use gksu

Jan Heitkötter usenet-09 at heitkoetter.net
Sat Apr 11 09:29:57 UTC 2009

Package: gnome-utils
Severity: wishlist
File: /usr/bin/gnome-system-log

Applications menu entry for gnome-system-log is installed using gksu per 
default. root privileges are not required for reading the major part of 
log files, being member of the adm group should be sufficient. 
Therefore, the menu entry shouldn't be installed with gksu by default.



-- System Information:
Debian Release: 5.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gnome-utils depends on:
ii  e2fslibs               1.41.3-1          ext2 filesystem libraries
ii  gconf2                 2.22.0-1          GNOME configuration database syste
ii  libart-2.0-2           2.3.20-2          Library of functions for 2D graphi
ii  libatk1.0-0            1.22.0-1          The ATK accessibility toolkit
ii  libbonobo2-0           2.22.0-1          Bonobo CORBA interfaces library
ii  libbonoboui2-0         2.22.0-1          The Bonobo UI library
ii  libc6                  2.7-18            GNU C Library: Shared libraries
ii  libcairo2              1.6.4-7           The Cairo 2D vector graphics libra
ii  libdbus-1-3            1.2.1-5           simple interprocess messaging syst
ii  libfontconfig1         2.6.0-3           generic font configuration library
ii  libfreetype6           2.3.7-2           FreeType 2 font engine, shared lib
ii  libgconf2-4            2.22.0-1          GNOME configuration database syste
ii  libglade2-0            1:2.6.2-1         library to load .glade files at ru
ii  libglib2.0-0           2.16.6-1+lenny1   The GLib library of C routines
ii  libgnome-desktop-2     2.22.3-2          Utility library for loading .deskt
ii  libgnome2-0          The GNOME 2 library - runtime file
ii  libgnomecanvas2-0        A powerful object-oriented display
ii  libgnomeprint2.2-0     2.18.5-1          The GNOME 2.2 print architecture -
ii  libgnomeprintui2.2-0   2.18.3-1          GNOME 2.2 print architecture User 
ii  libgnomeui-0         The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0         1:2.22.0-5        GNOME Virtual File System (runtime
ii  libgtk2.0-0            2.12.11-4         The GTK+ graphical user interface 
ii  libgtop2-7             2.22.3-1          gtop system monitoring library
ii  libhal1                0.5.11-8          Hardware Abstraction Layer - share
ii  libice6                2:1.0.4-1         X11 Inter-Client Exchange library
ii  liborbit2              1:2.14.13-0.1     libraries for ORBit2 - a CORBA ORB
ii  libpanel-applet2-0     2.20.3-5          library for GNOME Panel applets
ii  libpango1.0-0          1.20.5-3          Layout and rendering of internatio
ii  libpixman-1-0          0.10.0-2          pixel-manipulation library for X a
ii  libpng12-0             1.2.27-2+lenny2   PNG library - runtime
ii  libpopt0               1.14-4            lib for parsing cmdline parameters
ii  libsm6                 2:1.0.3-2         X11 Session Management library
ii  libstartup-notificatio 0.9-1             library for program launch feedbac
ii  libx11-6               2:1.1.5-2         X11 client-side library
ii  libxcb-render-util0    0.2.1+git1-1      utility libraries for X C Binding 
ii  libxcb-render0         1.1-1.1           X C Binding, render extension
ii  libxcb1                1.1-1.1           X C Binding
ii  libxext6               2:1.0.4-1         X11 miscellaneous extension librar
ii  libxml2                2.6.32.dfsg-5     GNOME XML library
ii  libxrender1            1:0.9.4-2         X Rendering Extension client libra
ii  rarian-compat [scrollk 0.8.1-1           Rarian is a documentation meta-dat
ii  zlib1g                 1: compression library - runtime

Versions of packages gnome-utils recommends:
ii  gksu                          2.0.0-8    graphical frontend to su

Versions of packages gnome-utils suggests:
ii  gcalctool                    5.22.3-2    A GTK2 desktop calculator
ii  yelp                         2.22.1-8+b1 Help browser for GNOME 2

-- no debconf information

More information about the pkg-gnome-maintainers mailing list