Bug#524410: xchat-gnome crashes when trying to join a channel

Stéphane Blondon stephane.blondon at gmail.com
Thu Apr 16 21:52:11 UTC 2009

Package: xchat-gnome
Version: 1:0.18-3
Severity: important

xchat-gnome crashes on several channel but not on everyone.

- Work with:
When launched, a pop-up asking for a server is printed. If I choose the
first one (gnomefr), it works. However it seems to be a channel and
to redirect automaticaly to GIMPNet.
If I connect to GIMPNet, then a pop-up to choose the channel is printed. I
can choose gnomefr.
In the two cases, I'm correctly connected and I can chatwithout problems.

- Does Not work with:
Launch xchat-gnome, connect to OFTC, choose a channel, click on 'Join'
then the crash occurs. If I close the pop-up asking to choose a channel,
I can't use the command: I can type anything (/list for example) but
when I hit Enter, nothing happens.

The crash when launched in a console:
stephane at degtyarov:~ $ LANG=C; xchat-gnome

(xchat-gnome:4443): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(xchat-gnome:4443): Gtk-WARNING **: GtkSpinButton: setting an adjustment
with non-zero page size is deprecated

(xchat-gnome:4443): GLib-CRITICAL **: g_strsplit: assertion `string !=
NULL' failed
Segmentation fault
## end ##

The Gtk-WARNING are printed everytime (=with or without a crash) and
before the channel popup appears.

Misc. informations that might be useful:
- It's not a spellcheck error because it's possible to choose the
channel in the folded menu of the channel popup. When I try it, the same
problem happens.
- The problem was present in the previous Debian release (Lenny). (sorry
to not report it :( )
- xchat package works well with problematic channel.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (600, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-486
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages xchat-gnome depends on:
ii  libatk1.0-0                  1.22.0-1    The ATK accessibility toolkit
ii  libc6                        2.9-4       GNU C Library: Shared libraries
ii  libcairo2                    1.8.6-2+b1  The Cairo 2D vector graphics libra
ii  libdbus-1-3                  1.2.12-1    simple interprocess messaging syst
ii  libdbus-glib-1-2             0.80-3      simple interprocess messaging syst
ii  libgconf2-4                  2.24.0-7    GNOME configuration database syste
ii  libglade2-0                  1:2.6.4-1   library to load .glade files at ru
ii  libglib2.0-0                 2.20.0-2    The GLib library of C routines
ii  libgnome2-0                  2.24.1-2    The GNOME 2 library - runtime file
ii  libgnomeui-0                 2.24.1-1    The GNOME 2 libraries (User Interf
ii  libgnomevfs2-0               1:2.24.0-2  GNOME Virtual File System (runtime
ii  libgtk2.0-0                  2.14.7-5    The GTK+ graphical user interface
ii  libnotify1 [libnotify1-gtk2. 0.4.5-1     sends desktop notifications to a n
ii  libpango1.0-0                1.22.4-2    Layout and rendering of internatio
ii  libperl5.10                  5.10.0-19   Shared Perl library
ii  libsexy2                     0.1.11-2+b1 collection of additional GTK+ widg
ii  libssl0.9.8                  0.9.8g-16   SSL shared libraries
ii  libx11-6                     2:1.2-1     X11 client-side library
ii  libxext6                     2:1.0.4-1   X11 miscellaneous extension librar
ii  python2.5                    2.5.4-1     An interactive high-level object-o
ii  tcl8.4                       8.4.19-3    Tcl (the Tool Command Language) v8
ii  xchat-gnome-common           1:0.18-3    a new frontend to the popular X-Ch

xchat-gnome recommends no packages.

xchat-gnome suggests no packages.

-- no debconf information


More information about the pkg-gnome-maintainers mailing list