Bug#540176: gksudo fails with sudo error message

Tar Possible tarposs at gmail.com
Thu Aug 6 12:23:58 UTC 2009

Package: gksu
Version: 2.0.2-2+b1
Severity: grave
Justification: renders package unusable

Running gksudo fails with the following error message:

sudo: sorry, a password is required to run sudo

Examples of commands to reproduce the above error:

gksudo synaptic
gksudo zenmap

Programs will run with appropriate permissions when sudo
instead of gksudo is used as, for example, in "sudo synaptic".
A Google search for the above error ("sudo: sorry, a" ...)
reveals a similar Ubuntu bug, which has been reported
as fixed:

[Reassigned synaptic bug]

[gksu bug]

Note that I have marked this as grave because this prevents
update manager from being launched when it is invoked
by clicking on the update notification icon (star with
downward pointing arrow) on the tray.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (900, 'testing'), (90, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-1-amd64 (SMP w/2 CPU cores)
Shell: /bin/sh linked to /bin/dash

Versions of packages gksu depends on:
ii  gnome-keyring                2.26.1-1    GNOME keyring services (daemon and
ii  libatk1.0-0                  1.26.0-1    The ATK accessibility toolkit
ii  libc6                        2.9-12      GNU C Library: Shared libraries
ii  libcairo2                    1.8.6-2+b1  The Cairo 2D vector graphics libra
ii  libfontconfig1               2.6.0-4     generic font configuration library
ii  libfreetype6                 2.3.9-4.1   FreeType 2 font engine, shared lib
ii  libgconf2-4                  2.26.2-3    GNOME configuration database syste
ii  libgksu2-0                   2.0.12-1    library providing su and sudo func
ii  libglib2.0-0                 2.20.1-2    The GLib library of C routines
ii  libgnome-keyring0            2.26.1-1    GNOME keyring services library
ii  libgtk2.0-0                  2.16.5-1    The GTK+ graphical user interface
ii  libpango1.0-0                1.24.0-3+b1 Layout and rendering of internatio
ii  libstartup-notification0     0.10-1      library for program launch feedbac
ii  sudo                         1.7.2-1     Provide limited super user privile

gksu recommends no packages.

gksu suggests no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list