Bug#544195: [CRASH] Uncaught exception TypeError in Frontend/Gtk/ui.py:953

Stephan Peijnik debian at sp.or.at
Sun Aug 30 08:40:10 UTC 2009

tag 544195 +confirmed
clone 544195 -1
retitle -1 Smart-upgrade dialog pops up multiple times

On Sat, 2009-08-29 at 08:28 -0500, Mark Petersen wrote:
> Package: update-manager-gnome
> Version: 0.200.0~rc2-1
> Severity: normal
> File: /usr/share/pyshared/UpdateManager/Frontend/Gtk/ui.py
> I'm sorry to say that this bug is not fixed in rc2.

This is (hopefully finally) fixed in 0.200.0~rc2-2, which should be
uploaded soon.

> Another issue that I am seeing is after the update-manger window opens, I am asked
> whether or not I want to smart-upgrade. If I answer no another pop-up window opens
> and asks me again if I want to smart-upgrade. - Not sure if this is a bug or a feature.

This needs some investigation. I will have a look at this and fix it
asap (might take a few days). It's not a feature, but a bug, to clarify

> Finally, update-manger-gnome conflicts with update-notifier. Now I am not seeing an
> update available notification when updates are available. Is a newer update-notifier
> coming or is update-manager-gnome suppose to notify?

A new update-notifier, that is built from the update-manager source
package is in the works right now, however, the problem seems to be in
the update-notifier package, as it depends on update-manager (which has
been replaced by update-manager-gnome).

More information about the pkg-gnome-maintainers mailing list