Bug#533840: gnome-session: switches to metacity from other window manager on upgrade

Lionel Elie Mamane lionel at mamane.lu
Sat Jun 20 19:34:19 UTC 2009

Package: gnome-session
Version: 2.26.1-7
Severity: normal

I had a working Gnome setup with sawfish. Sawfish was getting started
automatically because I had set that in System / Preferences /
Sessions (which seems to have disappeared now...): once in the distant
past, removed metacity from there and started sawfish and asked
gnome-session to remember what was currently running (including

Now Gnome starts metacity. For what reason it decided to ignore my
already set preference, I cannot fathom, but I consider it a bug. I
suspect the upgrade from gnome-session 2.22 to 2.26.

aptitude:[UPGRADE] gnome-session 2.22.3-3 -> 2.26.1-6
aptitude:[UPGRADE] gnome-session 2.26.1-6 -> 2.26.1-7
aptitude:[UPGRADE] gnome-session-bin 2.26.1-6 -> 2.26.1-7
aptitude.2.gz:[UPGRADE] gnome-session 2.22.3-2 -> 2.22.3-3

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_LU.UTF-8, LC_CTYPE=fr_LU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gnome-session depends on:
ii  gnome-panel                  2.26.2-1    launcher and docking facility for 
ii  gnome-session-bin            2.26.1-7    The GNOME Session Manager - Minima
ii  gnome-settings-daemon        2.26.1-2    daemon handling the GNOME session 
ii  metacity                     1:2.26.0-2  lightweight GTK+ window manager
ii  sawfish                      1: a window manager for X11

gnome-session recommends no packages.

Versions of packages gnome-session suggests:
ii  desktop-base                  5.0.5      common files for the Debian Deskto
ii  gnome-keyring                 2.26.1-1   GNOME keyring services (daemon and
ii  gnome-user-guide [gnome2-user 2.24.2-2   GNOME user's guide

-- no debconf information

More information about the pkg-gnome-maintainers mailing list