Bug#519722: Crash on URLs containg (e.g.) %s

Daniel Leidert daniel.leidert at wgdd.de
Sat Mar 14 16:51:09 UTC 2009

Package: gnome-terminal
Version: 2.24.3-2
Severity: important

Hash: SHA1

I was recently editing a configuration file, which conatined an URL of
the form:


Trying to open this URL crashes all running gnome terminals. This might
be a problem in a used library. So fell free to reassign this report to
the correct package.

Regards, Daniel

- -- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (850, 'unstable'), (700, 'testing'), (550, 'stable'), (110, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gnome-terminal depends on:
ii  gnome-terminal-data        2.24.3-3      Data files for the GNOME terminal 
ii  libatk1.0-0                1.24.0-2      The ATK accessibility toolkit
ii  libbonobo2-0               2.24.1-1      Bonobo CORBA interfaces library
ii  libc6                      2.9-4         GNU C Library: Shared libraries
ii  libgconf2-4                2.24.0-7      GNOME configuration database syste
ii  libglib2.0-0               2.18.4-2      The GLib library of C routines
ii  libgnome2-0                2.24.1-2      The GNOME 2 library - runtime file
ii  libgnomeui-0               2.24.1-1      The GNOME 2 libraries (User Interf
ii  libgtk2.0-0                2.14.7-4+b1   The GTK+ graphical user interface 
ii  liborbit2                  1:2.14.17-0.1 libraries for ORBit2 - a CORBA ORB
ii  libpango1.0-0              1.22.4-2      Layout and rendering of internatio
ii  libstartup-notification0   0.9-1         library for program launch feedbac
ii  libvte9                    1:0.17.4-2+b1 Terminal emulator widget for GTK+ 
ii  libx11-6                   2:1.2-1       X11 client-side library
ii  rarian-compat [scrollkeepe 0.8.1-1       Rarian is a documentation meta-dat

Versions of packages gnome-terminal recommends:
ii  yelp                          2.24.0-2   Help browser for GNOME 2

gnome-terminal suggests no packages.

- -- no debconf information

Version: GnuPG v1.4.9 (GNU/Linux)


More information about the pkg-gnome-maintainers mailing list