Bug#550478: gobject-introspection: Please include the Everything-1.0 typelib

Andreas Rottmann a.rottmann at gmx.at
Sat Oct 10 12:56:49 UTC 2009

Package: gobject-introspection
Version: 0.6.5-2
Severity: minor

Currently, Everything-1.0.typelib is not included in any binary
package built from the gobject-introspection source package; while it
is not needed for normal runtime operation of software using
gobject-introspection, it is commonly used in test suites of language
bindings. I'd suggest to add it to libgirepository1.0-dev.

Thanks, Rotty

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=C, LC_CTYPE=de_AT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages gobject-introspection depends on:
ii  libc6                         2.9-27     GNU C Library: Shared libraries
ii  libffi5                       3.0.7-3    Foreign Function Interface library
ii  libgirepository1.0-0          0.6.5-2    Library for handling GObject intro
ii  libglib2.0-0                  2.22.1-1   The GLib library of C routines
ii  python                        2.5.4-2    An interactive high-level object-o
ii  python-central                0.6.11     register and build utility for Pyt

gobject-introspection recommends no packages.

gobject-introspection suggests no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list