Bug#550600: fails to build with newer eglibc

Stefan Potyra sistpoty at ubuntu.com
Sun Oct 11 14:04:50 UTC 2009

Package: libsoup
Version: 2.2.105-4
Severity: normal
Tags: patch


during Ubuntu's rebuild test, libsoup failed to build with the newer 
eglibc [1], since it provides a definition for dprintf.

Attached is a patch that changes the local defintions of dprintf to



-- System Information:
Debian Release: squeeze/sid
  APT prefers karmic-updates
  APT policy: (500, 'karmic-updates'), (500, 'karmic-security'), (500, 'karmic')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.31-12-generic (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 02_dprintf.patch
Type: text/x-diff
Size: 36129 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-gnome-maintainers/attachments/20091011/99f98af8/attachment-0001.patch>

More information about the pkg-gnome-maintainers mailing list