Bug#576226: gnome-orca: Orca doesn't start at all

Odd Martin Baanrud martin at lb7ye.net
Thu Apr 1 18:30:04 UTC 2010

Package: gnome-orca
Version: 2.22.2-1
Severity: grave
Justification: renders package unusable

I'm using a Braillex EL80 braille display.
I've just tried to install gnome-orca.
When I've loged into gdm, I pressed Alt+F2, and then typed "orca".
The braille display changed text for a very short time, so short that I 
couldn't read it, and then went back to "screen not in text mode".
Then, I jumped to a text console and tried to run orca from there.
It gave a bunch for error messages:

idim at kristin:~$ orca
GtkWarning: could
not open display
  warnings.warn(str(e), _gtk.Warning)
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/var/lib/python-support/python2.5/orca/orca.py", line 54, in 
    import pyatspi
  File "/usr/lib/python2.5/site-packages/pyatspi/__init__.py", line 44, 
in <module>
    reg = bonobo.activation.activate_from_id(REGISTRY_IID, 0, 0)

-- System Information:
Debian Release: 5.0.4
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages gnome-orca depends on:
ii  libgail-gnome-module 1.20.0-1            GNOME Accessibility Implementation
ii  libgnome-speech7     1:0.4.19-1          GNOME text-to-speech library
ii  python               2.5.2-3             An interactive high-level object-o
ii  python-brlapi        3.10~r3724-1+lenny1 Python bindings for BrlAPI
ii  python-glade2        2.12.1-6            GTK+ bindings: Glade support
ii  python-gnome2        2.22.0-1            Python bindings for the GNOME desk
ii  python-gtk2          2.12.1-6            Python bindings for the GTK+ widge
ii  python-pyatspi       1.22.1-1            Assistive Technology Service Provi
ii  python-support       0.8.4lenny1         automated rebuilding support for P

Versions of packages gnome-orca recommends:
ii  gnome-mag                1:0.15.0-1      a screen magnifier for the GNOME d
ii  wget                     1.11.4-2+lenny1 retrieves files from the web

gnome-orca suggests no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list