Bug#591310: evince core dumps on djvu file

Norbert Preining preining at logic.at
Mon Aug 2 02:47:18 UTC 2010

Package: evince
Version: 2.30.3-1
Severity: important

Dear all,

I have  a strange problem with a djvu file:

- Loading it in evince crashes, my syslog contains:
evince[4555]: segfault at 7f1c32019dc8 ip 00007f1c3201ae40 sp 00007fff80fc5980 error 7 in libdjvulibre.so.21.1.0[7f1c31ef3000+183000] in libdjvulibre.so.21.1.0[7f1c31ef3000+183000]

- Loading it in djview(4) works without any problem, but both evince
  and djview(4) are linked to the same libdjvulibre library
  So I assume it is a bug in evince and *not* actually the libdjvu library.

- Installing evince-dbg and setting ulimit -c 100000 and checking that it
  is set, running evince I get
  	Segmentation fault (core dumped)
  and above error message, but *NO* core file is created!!!!

- running gdb on /usr/bin/evince I get:
Reading symbols from /usr/bin/evince...
warning: the debug information found in "/usr/lib/debug//usr/bin/evince" does not match "/usr/bin/evince" (CRC mismatch).

warning: the debug information found in "/usr/lib/debug/usr/bin/evince" does not match "/usr/bin/evince" (CRC mismatch).

(no debugging symbols found)...done.

Huuu? Didn't I install evince-dbg? Are the at the same version?

dpkg -l evince evince-dbg
ii  evince         2.30.3-1       Document (postscript, pdf) viewer
ii  evince-dbg     2.30.3-1       Document (postscript, pdf) viewer - debuggin


So this is a very strange error, which persisted over reboots.

Thanks for any suggestions.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.35-rc6+ (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages evince depends on:
ii  evince-common           2.30.3-1         Document (postscript, pdf) viewer 
ii  gconf2                  2.28.1-3         GNOME configuration database syste
ii  gnome-icon-theme        2.30.3-1         GNOME Desktop icon theme
ii  libatk1.0-0             1.30.0-1         The ATK accessibility toolkit
ii  libc6                   2.11.2-2         Embedded GNU C Library: Shared lib
ii  libcairo2               1.8.10-4         The Cairo 2D vector graphics libra
ii  libdbus-1-3             1.2.24-3         simple interprocess messaging syst
ii  libdbus-glib-1-2        0.86-1           simple interprocess messaging syst
ii  libevince2              2.30.3-1         Document (postscript, pdf) renderi
ii  libfontconfig1          2.8.0-2.1        generic font configuration library
ii  libfreetype6            2.4.0-2          FreeType 2 font engine, shared lib
ii  libgconf2-4             2.28.1-3         GNOME configuration database syste
ii  libglib2.0-0            2.24.1-1         The GLib library of C routines
ii  libgnome-keyring0       2.30.1-1         GNOME keyring services library
ii  libgtk2.0-0             2.20.1-1         The GTK+ graphical user interface 
ii  libice6                 2:1.0.6-1        X11 Inter-Client Exchange library
ii  libnautilus-extension1  2.30.1-1         libraries for nautilus components 
ii  libpango1.0-0           1.28.1-1         Layout and rendering of internatio
ii  libsm6                  2:1.1.1-1        X11 Session Management library
ii  libx11-6                2:1.3.3-3        X11 client-side library
ii  libxml2                 2.7.7.dfsg-4     GNOME XML library
ii  shared-mime-info        0.71-3           FreeDesktop.org shared MIME databa
ii  zlib1g                  1: compression library - runtime

Versions of packages evince recommends:
ii  dbus-x11                      1.2.24-3   simple interprocess messaging syst
ii  gvfs                          1.6.3-1    userspace virtual filesystem - ser

Versions of packages evince suggests:
ii  nautilus                      2.30.1-1   file manager and graphical shell f
ii  poppler-data                  0.4.3-1    Encoding data for the poppler PDF 
ii  unrar                         1:3.9.10-1 Unarchiver for .rar files (non-fre

-- no debconf information

More information about the pkg-gnome-maintainers mailing list