Bug#607049: python-webkit: missing python-geoclue dependency ?

arno renevier arno at renevier.net
Tue Dec 14 09:59:30 UTC 2010

Package: python-webkit
Version: 1.1.8-1
Severity: normal

after installing python-webkit, and running
> import webkit
from python shell, I get following exception:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/pymodules/python2.6/webkit/__init__.py", line 21, in <module>
    import webkit
ImportError: libgeoclue.so.0: cannot open shared object file: No such file or directory

After installing python-geoclue, This error disappears.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages python-webkit depends on:
ii  libatk1.0-0             1.30.0-1         The ATK accessibility toolkit
ii  libc6                   2.11.2-7         Embedded GNU C Library: Shared lib
ii  libcairo2               1.8.10-6         The Cairo 2D vector graphics libra
ii  libfontconfig1          2.8.0-2.1        generic font configuration library
ii  libfreetype6            2.4.2-2.1        FreeType 2 font engine, shared lib
ii  libglib2.0-0            2.24.2-1         The GLib library of C routines
ii  libgtk2.0-0             2.20.1-2         The GTK+ graphical user interface 
ii  libpango1.0-0           1.28.3-1         Layout and rendering of internatio
ii  libsoup2.4-1            2.30.2-1         an HTTP library implementation in 
ii  libwebkit-1.0-2         1.2.5-2.1        Web content engine library for Gtk
ii  libxml2                 2.7.8.dfsg-1     GNOME XML library
ii  libxslt1.1              1.1.26-6         XSLT 1.0 processing library - runt
ii  python                  2.6.6-3+squeeze3 interactive high-level object-orie
ii  python-gtk2             2.17.0-4         Python bindings for the GTK+ widge
ii  python-support          1.0.11           automated rebuilding support for P
ii  zlib1g                  1: compression library - runtime

python-webkit recommends no packages.

python-webkit suggests no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list