Bug#607557: libpanelappletmm-2.6-dev: Always causes a segfault

Bastien Scher bastien0705 at aol.com
Sun Dec 19 18:30:34 UTC 2010

Package: libpanelappletmm-2.6-dev
Version: 2.26.0-1
Severity: grave
Justification: renders package unusable

I tried to write several programs using this library. All of them segfault,
even the examples provided with the package (and even with the "official"

Here's the backtrace from gdb :

#0  0x00007ffff6141430 in panel_applet_factory_main_closure () from /usr/lib
#1  0x0000000000406608 in Gnome::Panel::factory_main<ExampleApplet> (iid=...)
    at /usr/include/libpanelappletmm-2.6/libpanelappletmm/factory.h:99
#2  0x0000000000405dc1 in main (argc=1, argv=0x7fffffffe088) at main.cpp:23

It would be nice if this library was supported again, since it's very hard to
write an applet with gtkmm without it (I'm experiencing very strange bugs using
libpanel-applet with gtkmm).

-- System Information:
Debian Release: 6.0
  APT prefers unstable
  APT policy: (900, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.36-rc2nouveau+ (SMP w/2 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libpanelappletmm-2.6-dev depends on:
ii  libgconfmm-2.6-dev            2.28.0-1   C++ wrappers for GConf (developmen
ii  libgtkmm-2.4-dev              1:2.20.3-1 C++ wrappers for GTK+ (development
ii  libpanel-applet2-dev          2.30.2-2   library for GNOME Panel applets - 
ii  libpanelappletmm-2.6-1c2      2.26.0-1   C++ wrappers for libpanel-applet (

libpanelappletmm-2.6-dev recommends no packages.

libpanelappletmm-2.6-dev suggests no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list