Bug#572627: librsvg2-bin: CSS multiple class selectors fail

Toby Speight T.M.Speight.90 at cantab.net
Fri Mar 5 11:12:46 UTC 2010

Package: librsvg2-bin
Version: 2.26.0-1
Severity: normal

Viewing the included SVG file with rsvg-view (or converting it to PNG
with rsvg) shows the dashed line in black, meaning that the CSS for
".foo" and ".bar" has been applied, but not the rule for ".foo.bar".
Inkscape (and inkview) correctly show the dashed line in red.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: drawing.svg
Type: image/svg+xml
Size: 385 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-gnome-maintainers/attachments/20100305/2fd6c220/attachment-0001.svg>
-------------- next part --------------

Specification reference:

<URL: http://www.w3.org/TR/2008/REC-CSS2-20080411/selector.html#class-html >

rsvg also doesn't match using the full attribute-value syntax
"[class~=foo][class~=bar]" - perhaps it's internally using a CSS1
engine?  The SVG spec says that CSS2 selectors must be supported:

<URL: http://www.w3.org/TR/SVG11/styling.html#StylingWithCSS >

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (900, 'testing'), (900, 'stable'), (400, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30 (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages librsvg2-bin depends on:
ii  libc6                         2.10.2-6   Embedded GNU C Library: Shared lib
ii  libcairo2                     1.8.8-2    The Cairo 2D vector graphics libra
ii  libglib2.0-0                  2.22.4-1   The GLib library of C routines
ii  libgtk2.0-0                   2.18.6-1   The GTK+ graphical user interface 
ii  librsvg2-2                    2.26.0-1   SAX-based renderer library for SVG
ii  libx11-6                      2:1.3.3-1  X11 client-side library
ii  python                        2.5.4-9    An interactive high-level object-o

librsvg2-bin recommends no packages.

librsvg2-bin suggests no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list