Bug#650666: libpeas-1.0-0: Python plugin broken (again)

Pierre Haessig pierre.haessig at crans.org
Thu Dec 1 18:30:41 UTC 2011

Package: libpeas-1.0-0
Version: 1.2.0-1
Severity: important


There is an issue with gedit Python plugins failing to load, which I think is
related to libpeas. I believe I am reporting the same bug that was reported
(and apparently *fixed*) in Ubuntu some weeks ago :

In my case, the code comment gedit plugins doesn't load.
Here is gedit terminal output:

$ gedit

# [here I activate the code comment plugins in the GUI]

(gedit:24507): libpeas-WARNING **: Error initializing Python Plugin
Loader:PyGObject initialization failed
ImportError: could not import gobject (error was: 'No module named _gobject')

(gedit:24507): libpeas-WARNING **: Please check the installation of all the
Python related packages required by libpeas and try again

(gedit:24507): libpeas-WARNING **: Loader 'python' is not a valid
PeasPluginLoader instance

(gedit:24507): libpeas-WARNING **: Could not find loader 'python' for plugin

Additionaly, I have no such issue with my laptop running with libpeas 1.1.0-1
Also, to the best of my knowledge, this bug is not related to #647292


-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/6 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages libpeas-1.0-0 depends on:
ii  libatk1.0-0                 2.2.0-2    
ii  libc6                       2.13-21    
ii  libcairo-gobject2           1.10.2-6.1 
ii  libcairo2                   1.10.2-6.1 
ii  libffi5                     3.0.10-3   
ii  libfontconfig1              2.8.0-3    
ii  libfreetype6                2.4.8-1    
ii  libgdk-pixbuf2.0-0          2.24.0-1   
ii  libgirepository-1.0-1       0.10.8-2+b1
ii  libglib2.0-0                2.30.2-4   
ii  libgtk-3-0                  3.0.12-2   
ii  libjavascriptcoregtk-3.0-0  1.6.1-5+b1 
ii  libpango1.0-0               1.29.4-2   
ii  libpeas-common              1.2.0-1    
ii  libpython2.7                2.7.2-7    
ii  libseed-gtk3-0              3.0.0-2    
ii  libsoup2.4-1                2.34.3-1   
ii  libwebkitgtk-3.0-0          1.6.1-5+b1 

libpeas-1.0-0 recommends no packages.

libpeas-1.0-0 suggests no packages.

-- no debconf information

More information about the pkg-gnome-maintainers mailing list