Bug#648220: After upgrade to gdm3 session selection defaults to "system default"

Marcus Comstedt marcus.comstedt at 27m.se
Mon Dec 5 16:09:57 UTC 2011

Package: gdm3
Version: 3.0.4-4
Followup-For: Bug #648220

Dear Maintainer,

I'm also affected by this problem, and have observed the following:

If you click on a face in the face browser, then the correct session
for that user is selected.  However, if you type the username manually
(either because you have disabled the face browser, or because you
 click on "Other"), then it does not work and you always get "system
default".  This used to work in old gdm.

  // Marcus

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=sv_SE.ISO-8859-1 (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages gdm3 depends on:
ii  accountsservice                             0.6.15-2   
ii  adduser                                     3.113      
ii  dconf-gsettings-backend                     0.7.5-3    
ii  debconf [debconf-2.0]                       1.5.41     
ii  gconf2                                      2.32.4-1   
ii  gnome-session [x-session-manager]           3.0.2-3    
ii  gnome-session-bin                           3.0.2-3    
ii  gnome-session-fallback [x-session-manager]  3.0.2-3    
ii  gnome-terminal [x-terminal-emulator]        3.0.1-1    
ii  gsettings-desktop-schemas                   3.2.0-2    
ii  kterm [x-terminal-emulator]                 6.2.0-46   
ii  libaccountsservice0                         0.6.15-2   
ii  libatk1.0-0                                 2.2.0-2    
ii  libattr1                                    1:2.4.46-3 
ii  libaudit0                                   1.7.18-1   
ii  libc6                                       2.13-21    
ii  libcairo-gobject2                           1.10.2-6.1 
ii  libcairo2                                   1.10.2-6.1 
ii  libcanberra-gtk3-0                          0.28-3     
ii  libcanberra0                                0.28-3     
ii  libdbus-1-3                                 1.4.16-1   
ii  libdbus-glib-1-2                            0.98-1     
ii  libfontconfig1                              2.8.0-3    
ii  libfreetype6                                2.4.8-1    
ii  libgconf2-4                                 2.32.4-1   
ii  libgdk-pixbuf2.0-0                          2.24.0-1   
ii  libglib2.0-0                                2.30.2-4   
ii  libglib2.0-bin                              2.30.2-4   
ii  libgtk-3-0                                  3.0.12-2   
ii  libpam-modules                              1.1.3-6    
ii  libpam-runtime                              1.1.3-6    
ii  libpam0g                                    1.1.3-6    
ii  libpango1.0-0                               1.29.4-2   
ii  librsvg2-common                             2.34.2-1   
ii  libselinux1                                 2.1.0-4    
ii  libupower-glib1                             0.9.14-3   
ii  libwrap0                                    7.6.q-21   
ii  libx11-6                                    2:1.4.4-4  
ii  libxau6                                     1:1.0.6-4  
ii  libxdmcp6                                   1:1.1.0-4  
ii  libxklavier16                               5.1-2      
ii  libxrandr2                                  2:1.3.2-2  
ii  lsb-base                                    3.2-28     
ii  metacity [x-window-manager]                 1:2.34.1-2 
ii  policykit-1-gnome                           0.105-1    
ii  sawfish [x-window-manager]                  1:
ii  twm [x-window-manager]                      1:1.0.6-1  
ii  upower                                      0.9.14-3   
ii  xterm [x-terminal-emulator]                 276-1      

Versions of packages gdm3 recommends:
ii  at-spi                 1.32.0-1      
ii  desktop-base           6.0.7         
ii  gnome-icon-theme     
ii  gnome-power-manager    3.0.2-3       
ii  gnome-settings-daemon  3.0.3-3       
ii  x11-xkb-utils          7.6+4         
ii  xserver-xephyr         2:
ii  xserver-xorg           1:7.6+9       
ii  zenity                 3.2.0-1       

Versions of packages gdm3 suggests:
ii  gnome-mag             <none>    
ii  gnome-orca            <none>    
ii  gok                   <none>    
ii  libpam-gnome-keyring  3.0.3-2   
ii  metacity              1:2.34.1-2

-- Configuration Files:
/etc/gdm3/greeter.gconf-defaults changed [not included]
/etc/gdm3/greeter.gsettings changed [not included]

-- debconf information excluded

More information about the pkg-gnome-maintainers mailing list